[ubuntu-mono] Ubuntu: Use of Mono and MonoDevelop

Haeusler, Reinhard reinhard.haeusler at siemens.com
Tue Dec 5 19:32:40 GMT 2006


Hello,
 
I am a new user of your Ubuntu (Gnome) Linux distribution "6.10 RC1" (got the CD from a colleague) - congratulations to that distribution - it works really good on my old PC at home (without internet connection)!
 
I have no real experience with Mono now, but I will try to get it using your Ubuntu distribution. Currently there is Mono only particular (only the runtime 'mono') installed.
 
Please can you provide me with some hints, how I can use the 'Mono' development environment (at least the compiler 'mcs' and the tool 'monop' additional to the CLR 'mono') and the IDE 'MonoDevelop' (with the tool 'MonoDoc').
 
The following information is from the web-site of MonoDevelop (http://www.monodevelop.com/Main_Page) and holds the names of the source tarballs:
 
The current MonoDevelop is 0.12 (monodevelop-0.12.tar.gz) - needs Mono 1.1.10 (at least) and the following packages:
    gtk-sharp-2.4.2.tar.gz, gtksourceview-sharp-2.0-0.10.tar.gz, monodoc-1.1.9.tar.gz, gecko-sharp-2.0-0.11.tar.gz.
 
The previous MonoDevelop is 0.11 (monodevelop-0.11.tar.gz <http://monodevelop-0.11.tar.gz/> ) - possibly the version which fits best in in my Ubuntu (6.10 RC1) - needs Mono 1.1.10 (at least) - but don`t know the packages!
    (In the release notes I con only find one difference between MD 0.11 and MD 0.12 at all: gtk-sharp-2.4.0 in MD 0.11 instead of gtk-sharp.2.4.2 in MD 0.12.)  
 
The following informations are from the web-site of Mono (http://www.mono-project.com/Main_Page) and holds links to the lists of the source tarballs:
 
The needed Mono is 1.1.10[.1] (holds 15 packages - see http://go-mono.com/archive/1.1.10/sources/ or http://go-mono.com/archive/1.1.10.1/sources/ for details).
The version of Mono in my Ubuntu (6.10 RC1) is 1.1.17[.1|.2] (holds 22 packages - see http://go-mono.com/archive/1.1.17/sources/ or http://go-mono.com/archive/1.1.17.1/sources/ or http://go-mono.com/archive/1.1.17.2/sources/ for details).
Note: Mono 1.1.17 holds MonoDevelop 0.11 (the previous), but Mono 1.1.17.1 and Mono 1.1.17.2 both holds MonoDevelop 0.12 (the latest).
 
The version of Mono afterwards is 1.1.18 (holds 22 packages - see http://go-mono.com/archive/1.1.18/sources/ for details).
 
The current Mono is 1.2[.1] (holds 22 packages - see http://go-mono.com/archive/1.2/sources/ or http://go-mono.com/archive/1.2.1/sources/ for details).
 
Please can you give me the location where I can get the appropriate packages or how to do the installation from source on my Ubuntu (6.10 RC1).
I need to download all packages before I can transfer them on my old PC at home.
 
If you don`t know a complete answer ! am happy to get a hint, how I can start to find a solution - possibly I can help you also.
 
Many thanks and I wish you more and more success with your Ubuntu distribution, especially with Mono on it.
 
Best regards,  Reinhard Häusler
 
 
Reinhard Häusler
Siemens Austria - PSE KB C1
reinhard.haeusler at siemens.com
 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-mono/attachments/20061205/709b4da1/attachment.htm 


More information about the Ubuntu-mono mailing list