[ubuntu-ko] PPA 패키지들의 버전..

Changwoo Ryu cwryu at debian.org
Sun Jun 6 03:57:49 BST 2010


PPA에 버전이 잘못되어 있습니다. 버전 정책을 따라 주세요.

https://help.launchpad.net/Packaging/PPA/BuildingASourcePackage

If you're creating an alternative version of a package already available
in Ubuntu's repositories, you should ensure that: 

      * your package supersedes the official Ubuntu version 
      * future Ubuntu versions will supersede your package.

hunspell, hunspell-dict-ko, nabi 따위는 데비안을 통해 우분투 메인에 들어
가는 패키지인데 패키지 리비전을 -1 이렇게 붙여 버리시면 나중에 버전업할
때 문제가 됩니다. 리비전을 바꾸지 말고 뒤에 ppa1 따위를 붙이셔야 합니다.


그리고, 이왕이면 메인 패키지에 반영되도록 좀 더 적극적이 될 수는 없을까
요? 물론 구버전이 답답하고, 영어로 리포트하고 수정되는 거 확인하는 일이
귀찮으니, 그냥 내가 만들어서 PPA에 업로드해 버리는 게 덜 답답할 수도 있
는데요. 자꾸 이렇게 자기만의 솔루션을 찾아나가는 것보다는 우분투 메인에
버전업을 독촉하는 게 장기적으로도 PPA 관리보다 덜 귀찮은 일입니다. 이렇
게 업스트림 버전업을 위해 활용하는 건 PPA의 의도가 아닙니다.

-- 
Changwoo Ryu <cwryu at debian.org>
-------------- next part --------------
텍스트가 아닌 첨부를 모두 없애 버렸습니다...
이름: 이용할 수 없숩니다.
형식: application/pgp-signature
크기: 186 bytes
설명: This is a digitally signed message part
Url : https://lists.ubuntu.com/archives/ubuntu-ko/attachments/20100606/fe4d3db7/attachment.pgp