[ubuntu-it] grub2 non vede tutti gli OS...

Mario mariogolf2 a tiscali.it
Sab 21 Apr 2012 23:14:50 UTC


Cari "colleghi" ;) ,

sto facendo alcune prove, installando vari OS Linux, tra cui Debian 6 e 7.
Lavoro principalmente in Kubuntu Maverick 64bit.
Oggi ho installato debian6, ma non riesco a farlo vedere ad ubuntu!

Mi spiego meglio. Questo grosso modo le partizioni:

SDA (grub2  installato nell'mbr e punta a sda1):
    sda1    /boot
    sda2    lucid
    sda5    /
    sda6-12 altri os inseriti in automatico in grub2

sdb + sdc RAID1 /home

SDD (grub2  installato nell'mbr e punta a sdd1)
    sdd1    /boot di sdd2
    sdd2    / (LVM2 debian6)
    sdd3    LVM2 - dati

Ora: quando avvio da sda vedo nell'elenco i SO presenti nel pc. Ma solo
quelli in sda.

Non c' verso di far vedere a grub (in sda) il SO in sdd1 e fare il boot.
Ho reinstallato grub2 sia in maverick che in debian6, ho dato os-prober,
sparso update-grub come fossero caramelle... ma niente!

Cos per avviare sdd1/sdd2 devo cambiare il disco di avvio nel BIOS... e
non  comodo...
La cosa paradossale  che debian6 in sdd2 vede e avvia correttamente
*tutti* i SO anche di sda.

Spero di esser stato chiaro....
C' qualche possibilit di "risolvere"?
Mi aiutate?

Ciao, Mario

PS.: versione di grub2 in Maverick: 1.98+20100804-5ubuntu3.3

-------------- parte successiva --------------
Un allegato non testuale  stato rimosso....
Nome:        signature.asc
Tipo:        application/pgp-signature
Dimensione:  262 bytes
Descrizione: OpenPGP digital signature
URL:         <https://lists.ubuntu.com/archives/ubuntu-it/attachments/20120422/a4348d4a/attachment-0001.pgp>


Maggiori informazioni sulla lista ubuntu-it