[ubuntu-it] Grub 2 - problemi all'avvio

Felix lccflc a email.it
Mar 5 Gen 2010 15:18:33 GMT


Piviul ha scritto:
> Felix scrisse in data 05/01/2010 03:58:
>   
>> Ciao,
>> Ho seguito alcuni consigli per far apparire la finestra di avvio di
>> grub ma mi si è incasinato.
>> Non sono riuscito più ad avviarlo per cui ho reinstallato daccapo
>> Karmic e poi ho ripristinato un backup.
>> Ho dovuto procedere così perchè in nessun altro modo sono riuscito a
>> ripristinare grub ed ad avviare la macchina.
>> Ora mi si impianta all'avvio 2 volte sì ed 1 no.
>>     
> Come vedi reinstallare in linux serve a poco... sei sicuro che c'entri
> grub? dove si blocca? Sai che per vedere il menù di grub non devi più
> premere [esc] ma [shift]? Ti consiglio quando riesci ad avviarlo a
> controllare bene i log per vedere il motivo per cui ha fallito la volta
> precedente.
> Ciao e in bocca al lupo
> Piviul

Non credo, suppongo invece che c'entri parecchio:
- il sistema era stato reinstallato daccapo il giorno 2 a seguito della 
"piallata" data a Windows... e l'ho fatto perchè ho paura di mettere 
mano al nuovo grub, almeno fino a quando non ci saranno guide esaustive;
- funzionava come un orologio;
- dopo aver premuto quel maledetto "shift" è andato in tilt;
- ha cominciato a segnalare errori di tutti i tipi e mi ha sputtanato 
l'fstab... è certo in quanto prima di piallare (per pura disperazione) 
ho avuto modo di dare un'occhiata ai log (c'erano gli orari non 
dimentichiamolo);
- ho cercato di riparare come descritto in questa pagina: 
http://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino 
tentando più e più volte;
- ho cercato di utilizzare SistemRescue e SuperGrub ma, come ovvio, 
fungono solo con grub 1.

E comunque, dopo 1/2 giornata (sono andato a letto stamattina alle 7 
meno 10) mi ha più volte riproposto un errore:

*"One or more of the mount listed in /etc/fstab cannot yet be mounted: 
swap: waiting UUID=segue numero della partizione di swap
ed ancora /proc/bus/usb: waiting for none"*

In verità /etc/fstab mi segnala anche un problema con la partizione 
/dev/hda6 (che è la mia "/root") che credo rimonti ad ogni avvio.
Invece il problema legato a /proc/bus/usb è probabilmente legato al 
fatto che ho dimenticato di commentare le ultime due linee del fstab 
relative all'utilizzo delle USB in Virtualbox il cui supporto, con 
Karmic, ora funziona semplicemente abilitando l'utente nel gruppo 
"vboxusers" (prima che mi facciate la classica domanda ecco il responso: 
"vboxusers:x:122:felix,root").

Tutto come si legge dal mio fstab... le ultime due linee sono state 
eliminate ed è spartito l'errore USB però continua ad avviarsi 1 volta 
sì e 2 no.

Ho paura di modificare valori e stringhe in quanto è il PC di lavoro... 
qualcuno mi dà un consiglio? grazie in anticipo :-)

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda6 during installation
UUID=7eac5366-4551-4901-8745-9f6ddc3abe77 /               ext4    
errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=55ca54a4-7f5f-44ae-b009-3c3670615b21 /boot           ext4    
defaults        0       2
# /home was on /dev/sda7 during installation
UUID=8685280b-c5e3-44d7-a5d2-ef70c14369ee /home           ext4    
defaults        0       2
# swap was on /dev/sda5 during installation
UUID=c7e60626-22e9-47e1-a3e0-bea4bdd82ff3 none            swap    
sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
## USB per Virtualbox
none /proc/bus/usb usbfs devgid=122,devmode=664 0 0
-------------- parte successiva --------------
Un allegato HTML è stato rimosso...
URL: https://lists.ubuntu.com/archives/ubuntu-it/attachments/20100105/686b15d1/attachment.htm 


Maggiori informazioni sulla lista ubuntu-it