[ubuntu-it] Ubuntu 9.10 e scheda wireless disattivata.

Mailing pigna lucapml a gmail.com
Gio 5 Nov 2009 08:49:26 GMT


Ciao a tutti, ho appena insallato Ubuntu 9.10 sul mio portatile Asus L4500RBP.

Tutto  andato bene, tranne il wireless :(.

I passi che ho fatto sono:
1) Installato Ubuntu 9.10
2) Scaricati gli ultimi aggiornamenti
3) Lanciato Driver Hardware e installati i driver della scheda
wireless Broadcom B43Legacy e del modem
Ora la scheda di rete wire la vede correttamente per non si connette
e non mi permette di creare nuove reti wireless.
Se clicco col tasto dx sul network manager la voce "Abilita rete senza
fili"  in grigio chiaro e non selezionabile.
Mentre se clicco col tasto sx per selezionare una rete le reti
wireless non mi appaiono (ne avevo create 2 in precedenza e le ho
importate).

Con il comando dmesg mi appaiono i seguenti messaggi:

[ 3335.472536] b43legacy-phy1: Broadcom 4301 WLAN found
[ 3335.496040] b43legacy-phy1 debug: Found PHY: Analog 0, Type 1, Revision 4
[ 3335.496071] b43legacy-phy1 debug: Found Radio: Manuf 0x17F, Version
0x2053, Revision 2
[ 3335.520048] b43legacy-phy1 debug: Radio initialized
[ 3335.608072] b43legacy ssb0:0: firmware: requesting b43legacy/ucode2.fw
[ 3335.653785] b43legacy ssb0:0: firmware: requesting b43legacy/pcm4.fw
[ 3335.665766] b43legacy ssb0:0: firmware: requesting b43legacy/b0g0initvals2.fw
[ 3335.772056] b43legacy-phy1: Loading firmware version 0x127, patch
level 14 (2005-04-18 02:36:27)
[ 3335.829928] b43legacy-phy1 debug: Chip initialized
[ 3335.830234] b43legacy-phy1 debug: 30-bit DMA initialized
[ 3335.830435] b43legacy-phy1 debug: Wireless interface started
[ 3335.830446] b43legacy-phy1 debug: Adding Interface type 2
[ 3335.841253] b43legacy-phy1: Radio hardware status changed to DISABLED
[ 3335.841262] b43legacy-phy1 debug: Radio initialized
[ 3335.841745] b43legacy-phy1 debug: Removing Interface type 2
[ 3335.842050] b43legacy-phy1 debug: Wireless interface stopped
[ 3335.842172] b43legacy-phy1 debug: DMA-30 0x0260 (RX) max used slots: 0/64
[ 3335.842229] b43legacy-phy1 debug: DMA-30 0x0200 (RX) max used slots: 0/64
[ 3335.842283] b43legacy-phy1 debug: DMA-30 0x02A0 (TX) max used slots: 0/128
[ 3335.848674] b43legacy-phy1 debug: DMA-30 0x0280 (TX) max used slots: 0/128
[ 3335.859762] b43legacy-phy1 debug: DMA-30 0x0260 (TX) max used slots: 0/128
[ 3335.864047] b43legacy-phy1 debug: DMA-30 0x0240 (TX) max used slots: 0/128
[ 3335.872036] b43legacy-phy1 debug: DMA-30 0x0220 (TX) max used slots: 0/128
[ 3335.880044] b43legacy-phy1 debug: DMA-30 0x0200 (TX) max used slots: 0/128
[ 3335.888029] b43legacy-phy1 debug: Radio initialized
[ 3335.888048] b43legacy-phy1 debug: Radio initialized

Quello che no mi torna : "Radio hardware status changed to DISABLED"

Sul portatile non ho trovato nessun tastino per attivare/disattivare
la scheda wireless, e la spia del wifii  arancione.Se avvio Windows
XP la scheda funziona correttamente.

Prima avevo installato Ubuntu 9.04 e tutto funzionava alla perfezione.

Questo  l'output di lspci:

02:07.0 Network controller: Broadcom Corporation BCM4303 802.11b
Wireless LAN Controller (rev 02)

Questo  l'output di lshw -c network

*-network:0
   description: Ethernet interface
   product: BCM4401 100Base-T
   vendor: Broadcom Corporation
   physical id: 6
   bus info: pci a 0000:02:06.0
   logical name: eth0
   version: 01
   serial: 00:0e:a6:aa:23:d0
   size: 100MB/s
   capacity: 100MB/s
   width: 32 bits
   clock: 33MHz
   capabilities: pm bus_master cap_list ethernet physical mii 10bt
10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=b44
driverversion=2.0 duplex=full ip=192.168.3.150 latency=64 link=yes
multicast=yes port=twisted pair speed=100MB/s
   resources: irq:7 memory:fb200000-fb201fff
*-network:1
   description: Network controller
   product: BCM4303 802.11b Wireless LAN Controller
   vendor: Broadcom Corporation
   physical id: 7
   bus info: pci a 0000:02:07.0
   version: 02
   width: 32 bits
   clock: 33MHz
   capabilities: pm bus_master cap_list
   configuration: driver=b43-pci-bridge latency=64
   resources: irq:5 memory:fb100000-fb101fff
*-network:0 DISABLED
   description: Ethernet interface
   physical id: 1
   logical name: vboxnet0
   serial: 0a:00:27:00:00:00
   capabilities: ethernet physical
   configuration: broadcast=yes multicast=yes
*-network:1 DISABLED
   description: Wireless interface
   physical id: 2
   logical name: wlan0
   serial: 00:0e:a6:a8:ba:77
   capabilities: ethernet physical wireless
   configuration: broadcast=yes multicast=yes wireless=IEEE 802.11b

Grazie mille per l'aiuto.

--
----------------------------------------------
http://loziopigna.blogspot.com/



Maggiori informazioni sulla lista ubuntu-it