[ubuntu-it] perché mi connetto ma non navigo?

Giancarlo Pegoraro genkipegoraro a gmail.com
Mar 16 Set 2008 21:25:00 BST


Il giorno mar, 16/09/2008 alle 02.11 +0100, posta_evolve ha scritto: 
> ciao a tutti, mi sono appena iscritto
> volendo provare linux ho installato ubuntu 8.04
> Inizialmente non mi vedeva neppure la scheda di rete (realtek 8139), 
> solo dopo aver cambiato le proprietà della scheda (abilitato tutto e 
> messo su auto la negoziazione) si è accorto di essa e ora vado in
rete, 
> ma solo parzialmente (solo alcuni siti).
Tipico problema di DNS. Sai noi uomani ricordiamo piu' facilmente i nomi
l'opposto delle macchine (computer nel nostro caso:) che ricordano i
numeri. Per questo hanno messo "Il" "traduttore" :)

> Sono quasi completamente a digiuno di linux, sotto windows funziona 
> tutto perfettamente.
> Questo è il mio ifconfig:
> 
Sapere che esiste questo comando che deve essere lanciato da "terminale"
Beh!... :)

> eth0      Link encap:Ethernet  HWaddr 00:80:ca:55:26:25 
>           inet addr:192.168.0.2  Bcast:192.168.0.255
Mask:255.255.255.0
>           inet6 addr: fe80::240:caff:fe52:2625/64 Scope:Link
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:193 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:254 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000
>           RX bytes:159163 (155.4 KB)  TX bytes:29721 (29.0 KB)
>           Interrupt:16 Base address:0xd400
> 
> lo        Link encap:Local Loopback 
>           inet addr:127.0.0.1  Mask:255.0.0.0
>           inet6 addr: ::1/128 Scope:Host
>           UP LOOPBACK RUNNING  MTU:16436  Metric:1
>           RX packets:2472 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:2472 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:0
>           RX bytes:123600 (120.7 KB)  TX bytes:123600 (120.7 KB)
> 
C'e' qualcsa che mi sfugge ma vediamo se ce la facciamo. :-)
Di solito, in questo file ci sono scritte solo le prime due righe,
> 
> etc/network/interfaces:
queste vvvvv sotto
> auto lo
> iface lo inet loopback

ed hanno a che fare con il "loopback" (lo vedi scritto) Se non sai
cos'e' nel sito http:/a2.pluto informatica libera, nel volume III
sezione Comunicare, ci sono tutte le informazioni del caso :-)
Come dicevo il file sarebbe completo perche' il tutto e' gestito dal
"network manager" (o "wicd" tanto di moda ora :) con l'aiuto di
"avachi" (il demone preposto per questo)

Quello che scrivi quì sotto ha (o dovrebbe avere :) priorita' sulla
configurazione "dinamica"
> iface eth0 inet static
> address 192.168.0.2
> netmask 255.255.255.0
> gateway 192.168.0.1
> auto eth0

Pero' manca una (o due) riga fondamentale, l'indirizzo del server DNS.
Percio' dobbiamo scrivere anche

dns-nameservers 192.168.0.1

Io ho scritto l'indirizzo del "gateway" del tuo "router" (di solito e'
questo :)
Se vuoi puoi mettere gli openDns
dns-nameservers 208.67.222.222
dns-nameservers 208.67.220.220
oppure quelli del tuo provider, guarda un po' te :)
Ma sopratutto bisogna sapere cos'e' quello "scatolotto" che ti propina
il tuo fornitore di "adsl" e' un router? Oppure hai qualche altra
stranezza?

> qualche consiglio? 
Per il momento penso che possa bastare ;)

Ciao Genki ):o))




Maggiori informazioni sulla lista ubuntu-it