[ubuntu-it] Problemi di aggiornamento

Francesco Romaro francesco.romaro a tele2.it
Ven 19 Maggio 2006 14:14:41 BST


Ho provato a seguire le vostre indicazioni, e, dopo aver aggiunto "set
-x" il risultato  questo:

Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Correzione delle dipendenze in corso... Fatto
I seguenti pacchetti verranno inoltre installati:
  samba
Pacchetti raccomandati:
  smbldap-tools
I seguenti pacchetti saranno aggiornati:
  samba
1 aggiornati, 0 installati, 0 da rimuovere e 135 non aggiornati.
 necessario prendere 0B/2845kB di archivi.
Dopo l'estrazione, verranno occupati 0B di spazio su disco.
Continuare [S/n]?
Preconfigurazione dei pacchetti in corso
(Lettura del database ... 139584 file e directory attualmente
installati.)
Mi preparo a sostituire samba 3.0.22-1ubuntu2
(con .../samba_3.0.22-1ubuntu3_i386.deb) ...
+ '[' -x /etc/init.d/samba ']'
++ which invoke-rc.d
+ '[' -x /usr/sbin/invoke-rc.d ']'
+ invoke-rc.d samba stop
invoke-rc.d: dangling symlink: /etc/rc2.d/K09samba
+ exit 102
dpkg: attenzione - il vecchio script di pre-removal ha restituito un
codice di errore 102
dpkg - provo quindi lo script dal nuovo pacchetto ...
invoke-rc.d: dangling symlink: /etc/rc2.d/K09samba
dpkg: errore
processando /var/cache/apt/archives/samba_3.0.22-1ubuntu3_i386.deb
(--unpack):
 il sottoprocesso nuovo script di pre-removal ha restituito un codice di
errore 102
Sono occorsi degli errori processando:
 /var/cache/apt/archives/samba_3.0.22-1ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Aggiungo che, essendo un novizio, non so come risolvere il problema.

Francesco




More information about the ubuntu-it mailing list