[ubuntu-it] Problemi con nvidia e kernel vanilla

Sythos sythos a sythos.net
Mer 3 Maggio 2006 07:05:31 BST


Salve
ho recentemente installato dapper, ho messo su il kernel 2.6.16.12 e i driver
nvidia da sorgenti, pero' ho un problema con X, i driver glx non vengono
caricati, incollo qua il pezzo di log incriminato di Xorg7:

[cut]
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.0.0
        ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(WW) Warning, couldn't open module GLcore
(II) UnloadModule: "GLcore"
(II) UnloadModule: "glx"
(II) Unloading /usr/lib/xorg/modules/extensions/libglx.so
(EE) Failed to load module "glx" (a required submodule could not be loaded, 0)
[cut]

[cut2]
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Option "RenderAccel"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.
(II) NVIDIA(0): NVIDIA GPU GeForce FX 5200 at PCI:1:0:0
[cut2]

output of glxinfo is:
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None


location of glx/usr/lib/xorg/modules/extensions/libglx.so
/usr/lib/libglitz-glx.so.1.0.0
/usr/lib/libglx.so
/usr/lib/libglitz-glx.so.1
/usr/X11R6/lib/modules/extensions/libglx.so.1.0.8756
/usr/X11R6/lib/modules/extensions/libglx.so
/usr/lib/xorg/modules/extensions/libGLcore.so.1
/usr/lib/libGLcore.so.1.0.8756
/usr/lib/libGLcore.so.1
/usr/lib32/libGLcore.so.1.0.8756
/usr/lib32/libGLcore.so.1

X start, but without glx extension... and hint or idea?


-- 
Sythos - http://www.sythos.net

  ()  ASCII Ribbon Campaign - against html/rtf/vCard in mail
  /\                        - against M$ attachments



More information about the ubuntu-it mailing list