Custom Install using Ubiquity

Chris Larsen chris at enlight.us
Thu Dec 10 05:15:27 GMT 2009


I see via the edubuntu ubiquity page for automating installations that some things work and some things don't, by design and it makes some more sense now and i see that i can skip screens with the seen flag if using --automatic or preseeding automating. cool.. the link I'm referring to is: 



https://wiki.edubuntu.org/UbiquityAutomation 

So at this point I am really looking to find out, if pkgsel doesn't work then where can I find the procedure for installing extra packages through ubiquity. I am also interested in finding out where the best place to run final commands is. For example what i create in /usr/lib/ubiquity/target-config/50finish will work as "mkdir /var/testfolder" but a "50something" file with a slightly different directory name will not work. Also, it is confusing that some places refer to /target prepended to the path. 

Can someone just point me to a document that might be more explanatory than the aforepasted link? :) 

Thank you! 

Chris 


----- Original Message ----- 
From: "Chris Larsen" <chris at enlight.us> 
To: ubuntu-installer at lists.ubuntu.com 
Sent: Monday, December 7, 2009 9:54:57 PM GMT -06:00 US/Canada Central 
Subject: Custom Install using Ubiquity 



Hi, 

Forgive me if this is the most common question 

I have already successfully preseeded and heavily customized the alternate cd, and am proficient in creating livecd environments. I am now interested in customizing the 9.10 netbook remix Ubiquity-based installer to be able to a) add a non-dependent package from the main repo, b) add my own package into an extras repo, c) add some files into /etc/skel that will be present upon reboot, and d) add a script to /usr/local/bin visible upon reboot. So far, the various methods and countless hours and research have not been fruitful. 

Here is a high level overview of steps taken: 

Package install: 
-Tried to add a pkgsel line to preseed to add "editmoin" a random, nondependent app in the main repo ---> does not install. 
-Successfully generated my own key and signed a new Release file and put the generated deb's in the main repo on the cd ---> get apt configure failed error at 80%. viewing casper.log after first boot does complain about my public key not being available. I have signed and resigned, cleared directories first, you name it. Does this affect the main repo in turn not being accessible for that example "editmoin" app i tried to preseed? 

Post-install script: 
-Tried to use a simple one in preseed (same working approach/syntax used in alternate cd instance) that just creates a dir, chmod +x is on the file and #!/bin/sh is at the top: Does not create directory as noticed after first boot. 
-Went into the unsquashed live fs's /usr/lib/ubiquity dir and added a "50runscript" file (chmod +x) file in /target-config that does the same thing and the directory is not created upon install. I figure i could just create the files through scripts in /target-config or some place like that if ubiquity is not going to apply the preseed file as desired. NO GO :( 

Why is this not working for me in Ubiquity when i can get Alternate CD and the Live CD going without a hitch?? 

Thanks in advance, 

Chris 

-- Ubuntu-installer mailing list Ubuntu-installer at lists.ubuntu.com Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-installer 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-installer/attachments/20091209/16f49d7f/attachment.htm 


More information about the Ubuntu-installer mailing list