Fwd: Installing ubiquity from source on Ubuntu live cd.

Mario Limonciello superm1 at ubuntu.com
Mon Mar 17 14:12:24 GMT 2008


Pieter van Zyl wrote:
> Good day,
>
> I am trying to modify the Ubuntu Hardy Live desktop cd following the 
> instructions here:
> https://help.ubuntu.com/community/LiveCDCustomization
>
> I am busy modifying the Ubiquity installer(I checked out a branch)
>
> When I was using the iso image of Gutsy everything worked fine and I could 
> install the modified Ubiquity 1.7.4 on the extracted iso and rebuild the iso.
>
> I also obtained the newest version/branch from Ubiquity and created deb's and 
> tried to install these on Hardy Alpha5 without any modifications to the 
> installer and getting an error.
>
> When I try to install Ubiquity on the extracted iso image I get the following 
> errors:
>
>
>
>   
> Selecting previously deselected package ubiquity.
> (Reading database ... 101919 files and directories currently installed.)
> Unpacking ubiquity (from ubiquity_1.7.18_i386.deb) ...
> Selecting previously deselected package ubiquity-frontend-gtk.
> Unpacking ubiquity-frontend-gtk (from ubiquity-frontend-gtk_1.7.18_i386.deb)
> ...
> Selecting previously deselected package ubiquity-frontend-kde.
> Unpacking ubiquity-frontend-kde (from ubiquity-frontend-kde_1.7.18_all.deb)
> ...
> Selecting previously deselected package ubiquity-frontend-mythbuntu.
> Unpacking ubiquity-frontend-mythbuntu (from
> ubiquity-frontend-mythbuntu_1.7.18_all.deb) ...
> Adding `diversion of /usr/share/applications/ubiquity-gtkui.desktop to
> /usr/share/ubiquity/ubiquity-gtkui.desktop.diverted by
> ubiquity-frontend-mythbuntu'
> Adding `diversion of /usr/share/pixmaps/ubiquity.png to
> /usr/share/pixmaps/ubiquity-diverted.png by ubiquity-frontend-mythbuntu'
> Preparing to replace ubiquity-ubuntu-artwork 1.7.18 (using
> ubiquity-ubuntu-artwork_1.7.18_all.deb) ...
> Unpacking replacement ubiquity-ubuntu-artwork ...
> dpkg: dependency problems prevent configuration of ubiquity:
>  ubiquity depends on console-setup (>= 1.21ubuntu4); however:
>   Version of console-setup on system is 1.21ubuntu2.
>  ubiquity depends on python-central (>= 0.5.60); however:
>   Version of python-central on system is 0.5.50ubuntu7.
> dpkg: error processing ubiquity (--install):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of ubiquity-frontend-gtk:
>  ubiquity-frontend-gtk depends on libglib2.0-0 (>= 2.15.6); however:
>   Version of libglib2.0-0 on system is 2.15.5-0ubuntu1.
>  ubiquity-frontend-gtk depends on libpango1.0-0 (>= 1.19.4); however:
>   Version of libpango1.0-0 on system is 1.19.3-1ubuntu1.
>  ubiquity-frontend-gtk depends on python-central (>= 0.5.60); however:
>   Version of python-central on system is 0.5.50ubuntu7.
>  ubiquity-frontend-gtk depends on ubiquity; however:
>   Package ubiquity is not configured yet.
> dpkg: error processing ubiquity-frontend-gtk (--install):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of ubiquity-frontend-kde:
>  ubiquity-frontend-kde depends on kwin; however:
>   Package kwin is not installed.
>  ubiquity-frontend-kde depends on python-central (>= 0.5.60); however:
>   Version of python-central on system is 0.5.50ubuntu7.
>  ubiquity-frontend-kde depends on python-qt4; however:
>   Package python-qt4 is not installed.
>  ubiquity-frontend-kde depends on ubiquity; however:
>   Package ubiquity is not configured yet.
> dpkg: error processing ubiquity-frontend-kde (--install):
>  dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of
> ubiquity-frontend-mythbuntu:
>  ubiquity-frontend-mythbuntu depends on expect; however:
>   Package expect is not installed.
>  ubiquity-frontend-mythbuntu depends on lirc (>= 0.8.2-0ubuntu3); however:
>   Package lirc is not installed.
>  ubiquity-frontend-mythbuntu depends on mythbuntu-common; however:
>   Package mythbuntu-common is not installed.
>  ubiquity-frontend-mythbuntu depends on mythtv-common; however:
>   Package mythtv-common is not installed.
>  ubiquity-frontend-mythbuntu depends on python-central (>= 0.5.60); however:
>   Version of python-central on system is 0.5.50ubuntu7.
>  ubiquity-frontend-mythbuntu depends on ubiquity; however:
>   Package ubiquity is not configured yet.
>  ubiquity-frontend-mythbuntu depends on ubiquity-frontend-gtk; however:
>   Package ubiquity-frontend-gtk is not configured yet.
>  ubiquity-frontend-mythbuntu depends on vnc4-common; however:
>   Package vnc4-common is not installed.
> dpkg: error processing ubiquity-frontend-mythbuntu (--install):
>  dependency problems - leaving unconfigured
> Setting up ubiquity-ubuntu-artwork (1.7.18) ...
> Errors were encountered while processing:
>  ubiquity
>  ubiquity-frontend-gtk
>  ubiquity-frontend-kde
>  ubiquity-frontend-mythbuntu
> -------------------------------------------------------
>
> Any ideas? Problem with the alpha for not having the packages needed by 
> Ubiquity?
>
> Or do I need to modify ubiquity's dependencies? Rebuild the deb's?
>
> Or other problem?
>
> Kindly
>
> Pieter
>
>
>   
Pieter,

Don't install all of the debs created.  You likely only want one or two
of the frontends.  There are lots more dependencies to the GTK frontend
and the KDE frontend.  Additionally, to make sure all the dependencies
are really close in versioning, you should do this with one of the daily
disks instead.  You can grab one from  http://cdimages.ubuntu.com

Regards,

-- 
Mario Limonciello
superm1 at ubuntu.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-installer/attachments/20080317/70991b26/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
Url : https://lists.ubuntu.com/archives/ubuntu-installer/attachments/20080317/70991b26/attachment.pgp 


More information about the Ubuntu-installer mailing list