[ubuntu-in] keyserver.ubuntu.com timeout ..

Sanjay Bhangar sanjaybhangar at gmail.com
Fri Jan 15 06:28:08 GMT 2010

On Fri, Jan 15, 2010 at 8:55 AM, Ritesh Sinha <sinha.k.ritesh at gmail.com>wrote:

> On Fri, Jan 15, 2010 at 1:56 AM, Sanjay Bhangar <sanjaybhangar at gmail.com>
> wrote:
> > hey guys,
> >
> > Attempting to add a PPA from here:
> https://launchpad.net/~bzr/+archive/ppa<https://launchpad.net/%7Ebzr/+archive/ppa>
> >
> > Here is what I get at terminal:
> >
> > sanj at sanj:/var/www/oxjs$ sudo apt-key adv --keyserver
> keyserver.ubuntu.com
> > --recv-keys 8C6C1EFD
> > Executing: gpg --ignore-time-conflict --no-options --no-default-keyring
> > --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg
> > --keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com--recv-keys
> > 8C6C1EFD
> > gpg: requesting key 8C6C1EFD from hkp server keyserver.ubuntu.com
> > gpg: keyserver timed out
> > gpg: keyserver receive failed: keyserver error
> >
> > Is there any work-around for this? I have faced this problem quite a bit
> --
> > not sure what it's due to - my net connection seems okay.
> >
> It is most probably a firewall issue. I was facing a similar problem
> at work, when I tried the same using my home computer it worked
> perfectly. Some firewalls are configured to block traffic to non
> standard ports (other than 80/443 for HTTP/HTTPS). Check with your
> systems administrator.
> that makes total sense and is, in all probability, the cause of the
problem. I would however, like to avoid trying to get into this strange
conversation with my ISP ..
Me: Hello, err.. I'm trying to access the ubuntu keyserver which seems to be
using a non-standard port for https which you seem to be blocking?
Them: What?
Me: I err.. I'm trying to access something that's not working.
Them: Sir, can you click on Start button .. ?
Me: I don't have a Start button.
Them: What?
Me: Um, I use Ubuntu.
Them: Sir, it must be a virus. Can you please try restarting Windows and
trying again .. ?

Is there anything I can possiibly do that doesn't involve 'checking with my
system administrator'? Am okay with strange work-arounds, just not sure
where to start looking ...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-in/attachments/20100115/db674ffb/attachment.htm 

More information about the ubuntu-in mailing list