[ubuntu-in] BSNL Broadband does not work through Network Manager Applet in Ubuntu 9.10

Ramnarayan.K ramnarayan.k at gmail.com
Sat Dec 5 08:15:42 GMT 2009


Hi

Am setting up a fresh installation of Ubuntu 9.10 (Ultimate) .
Everything has gone well. The only issue is the BSNL Broadband

It is an ADSL connection and does not connect through the Network
Manager Applet.

I had to use use pppoeconf to set it up. Even on my laptop its the same problem

The modem is a Siemens C2110. And the connection is via ethernet. The
auto eth0 starts up and connects to the modem but it only allows
access to the device and no further.

Any idea what the problem could be.

Some time back on a similar network problem Shakthi Kannan posted a
network-debub script file
http://shakthimaan.com/downloads/glv/scripts/network-debug.sh

which i am using to attach the details below:

Would appreciate knowing whats wrong and how to rectify this.

***

Network Debug Helper Script
Version 1.1
http://www.gnu.org/licenses/gpl.txt
shakthimaan at gmail dot com

ifconfig --------------------------------------------------

eth0      Link encap:Ethernet  HWaddr 00:16:41:56:39:7d
          inet6 addr: fe80::216:41ff:fe56:397d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17410 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17875 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:18980808 (18.9 MB)  TX bytes:2174881 (2.1 MB)
          Memory:ee000000-ee020000

irda0     Link encap:IrLAP  HWaddr 00:00:00:00
          NOARP  MTU:2048  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:8
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:18 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2241 (2.2 KB)  TX bytes:2241 (2.2 KB)

pan0      Link encap:Ethernet  HWaddr d2:2a:f5:42:99:c3
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

ppp0      Link encap:Point-to-Point Protocol
          inet addr:117.205.131.73  P-t-P:117.205.128.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1460  Metric:1
          RX packets:17233 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17694 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:18590932 (18.5 MB)  TX bytes:1779838 (1.7 MB)

vboxnet0  Link encap:Ethernet  HWaddr 0a:00:27:00:00:00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:13:02:4d:55:bf
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr
00-13-02-4D-55-BF-00-00-00-00-00-00-00-00-00-00
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


iwconfig --------------------------------------------------


lspci -----------------------------------------------------


route -n --------------------------------------------------

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
117.205.128.1   0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0

resolv.conf -----------------------------------------------

nameserver 218.248.255.194
nameserver 218.248.255.162
# Generated by NetworkManager
domain local.lan
search local.lan

kernel ----------------------------------------------------

Linux ram-laptop 2.6.31-16-generic #52-Ubuntu SMP Thu Dec 3 22:00:22
UTC 2009 i686 GNU/Linux

loaded modules --------------------------------------------

Module                  Size  Used by
bridge                 47952  0
stp                     2272  1 bridge
bnep                   12060  2
btusb                  11856  2
xt_TCPMSS               3868  1
xt_tcpmss               1852  1
xt_tcpudp               2780  1
iptable_mangle          3452  1
pppoe                  11076  2
pppox                   3016  1 pppoe
binfmt_misc             8356  1
ppdev                   6688  0
vboxnetadp              7296  0
vboxnetflt             14344  0
vboxdrv               176360  3 vboxnetadp,vboxnetflt
kvm                   162688  0
dm_crypt               12928  0
snd_hda_codec_analog    59292  1
snd_hda_intel          26920  4
snd_hda_codec          75708  2 snd_hda_codec_analog,snd_hda_intel
snd_hwdep               7200  1 snd_hda_codec
snd_pcm_oss            37920  0
snd_mixer_oss          16028  1 snd_pcm_oss
snd_pcm                75296  5 snd_hda_intel,snd_hda_codec,snd_pcm_oss
joydev                 10272  0
snd_seq_dummy           2656  0
arc4                    1660  2
snd_seq_oss            28576  0
ecb                     2524  2
snd_seq_midi            6432  0
snd_rawmidi            22208  1 snd_seq_midi
snd_seq_midi_event      6940  2 snd_seq_oss,snd_seq_midi
snd_seq                50224  6
snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              22276  2 snd_pcm,snd_seq
iwl3945                77212  0
pcmcia                 36808  0
snd_seq_device          6920  5
snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
iwlcore               112540  1 iwl3945
snd                    59204  18
snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
thinkpad_acpi          67108  0
mac80211              181076  2 iwl3945,iwlcore
nsc_ircc               20976  0
soundcore               7264  1 snd
iptable_filter          3100  0
snd_page_alloc          9156  2 snd_hda_intel,snd_pcm
yenta_socket           24200  1
ip_tables              11692  2 iptable_mangle,iptable_filter
rsrc_nonstatic         11644  1 yenta_socket
pcmcia_core            35792  3 pcmcia,yenta_socket,rsrc_nonstatic
led_class               4096  3 iwl3945,iwlcore,thinkpad_acpi
psmouse                56500  0
x_tables               16544  4 xt_TCPMSS,xt_tcpmss,xt_tcpudp,ip_tables
cfg80211               93052  3 iwl3945,iwlcore,mac80211
irda                  189564  1 nsc_ircc
serio_raw               5280  0
lp                      8964  0
nvram                   7528  1 thinkpad_acpi
crc_ccitt               1852  1 irda
parport                35340  2 ppdev,lp
dm_raid45              84228  0
xor                    15620  1 dm_raid45
e1000e                122124  0
video                  19380  0
output                  2780  1 video
radeon                636000  2
ttm                    36212  1 radeon
drm                   159584  4 radeon,ttm
i2c_algo_bit            5760  1 radeon
intel_agp              27484  0
agpgart                34988  3 ttm,drm,intel_agp
ramzswap                8880  1
xvmalloc                5180  1 ramzswap
lzo_decompress          2620  1 ramzswap
lzo_compress            2300  1 ramzswap

***
Second problem is I deleted the Auto eth0 option in my network manager
(wired) to force the computer to pick up the ASDL link but now I
cannot get Auto eth0 back - even though i sent up a new auto eth0. And
the network manager applet now does not show anything to connect.

Would like advise on both problems

thanks
ram



More information about the ubuntu-in mailing list