[ubuntu-in] network-manager issues in ubuntu 8.10 (beta)

shirish shirishag75 at gmail.com
Sun Oct 12 12:50:25 BST 2008


Hi all,
 There is an issue in ubuntu 8.10 beta version as far as
network-manager is concerned. One of the many issues plaguing it atm
is that after every reboot or boot the preferences or variables are
blanked out .

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/279262

Now for self, have done a temporary workaround which works but I'm
sure this could be improved upon.

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/279262/comments/43

This is for ethernet wired connection to an ADSL router

a. sudo ifconfig eth0 inet 192.168.1.2 netmask 255.255.255.0 broadcast
61.1.96.69

b. ping -c5 192.168.1.1

c. sudo route add default gw 192.168.1.1

So I get something like this :-

route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0

I did a ping for the route man page says one should see that the
gateway is reachable.

After this things are happening coolly . Notice I'm not using any
NetworkManager stuff or anything.

The only thing issue atleast IMHO is that the preferences remain open
only for the session. Each session I have to do that :(

Comments, suggestions, additions to the above are welcome.
-- 
          Regards,
          Shirish Agarwal
  This email is licensed under http://creativecommons.org/licenses/by-nc/3.0/

065C 6D79 A68C E7EA 52B3  8D70 950D 53FB 729A 8B17



More information about the ubuntu-in mailing list