[ubuntu-hu] beryl - kihalt

Albert László-Róbert albertlaszlorobert at gmail.com
2007. Ápr. 23., H, 11:37:17 BST


Molnár Gábor wrote:
> Sziasztok,
>
> Updateltem 7-re az ubuntumat, és a beryl egy az egyben elhal fehér 
> képernyő bery és compizban is.
>
> Merre nézzek szét, mit csináljak első körben?
>
>
>
>
>
>   
nekem is ugyanez volt a problemam es ezeket kovetve sikerult megoldjam:

kovesd ezeket a beallitasokat (
http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_install_Beryl_.28ATI.29
es ezt 
http://wiki.beryl-project.org/wiki/Install_Beryl_on_Ubuntu_Feisty_with_XGL )

a lenyeg az, hogy a 7.04-esnek a repositoryjabol amit leszed (beryl
v0.2.1) az inkompatibilis az xgl-el. Es be kell allitanu, hogy egy
verzioval kesobbit szedje le (0.2.20-ast).

Lepesek:
-------------------------

    * Open a terminal:

Applications > Accessories > Terminal

    * Verify our system is up-to-date:

sudo apt-get update
sudo apt-get upgrade

    * Install Xgl (This is the main problem with ATI cards. The fglrx
      driver will not support the built-in Compiz feature in Ubuntu and
      we need Xgl to run our new version of Beryl with an ATI card.):

sudo apt-get install xserver-xgl

    * Write a script so Xgl can start on its own:

sudo gedit /usr/local/bin/startxgl.sh

    * Enter and save this script information:

#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
exec dbus-launch --exit-with-session gnome-session

    * If you are missing your shutdown and restart buttons, use this
      instead:

#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session

    * Make the script executable:

sudo chmod a+x /usr/local/bin/startxgl.sh

    * Now, we need to put in a Xgl option in our GDM login screen:

sudo gedit /usr/share/xsessions/xgl.desktop

    * Enter and save this script information:

[Desktop Entry]
Encoding=UTF-8
Name=GNOME with XGL
Comment=
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application

    * Also make this script executable:

sudo chmod a+x /usr/share/xsessions/xgl.desktop



    * Add the correct repository key:

sudo wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- |
sudo apt-key add -

    * Add the correct repository to the top of your apt source list:

sudo gedit /etc/apt/sources.list Enter: deb
http://ubuntu.beryl-project.org/ feisty main Save and close gedit

-----------------------
Itt majd mielott letoltened a berylt a kovetkezot kell csinald:

-----------------------

*/IMPORTANT -- Downgrading /beryl-core/ to 0.2.0/* 

The Ubuntu version of *beryl-core* is incompatible with Xgl. To install
a version of *beryl-core* that works, first run:

$ gksudo gedit /etc/apt/preferences

for Ubuntu, or for Kubuntu:

$ kdesu kate /etc/apt/preferences 

Then add the following to that file. If there are any other entries in
this file, separate this entry (all three lines) from those entries by a
blank line. Don't separate the three lines from each other.

Package: *
Pin: release o=lupine
Pin-Priority: 1000

Save the file.

This will cause your system to prefer beryl-project packages, but will
keep Ubuntu packages if they are manually installed, and newer.


-----------------------

Ez meg kellene oldja a problemadat. Nekem igy sikerult berobbantani a
berylt, hogy rendesen menjen.


remelem hasznalt.

udv
robee




További információk a(z) ubuntu-hu levelezőlistáról