Grub bug report

Ty Young bluesoviet at
Thu Mar 31 23:54:03 UTC 2016

Sorry for the late reply!

On 03/28/2016 03:58 AM, Narcis Garcia wrote:
> If you want Windows entries not appears in GRUB menu, you can disable
> the detection of other operating systems:
> chmod a-x /etc/grub.d/30_os-prober
> Than you can run update-grub with Windows HDD plugged, and menu will not
> include MS/Windows boot.
> Usually, when GRUB has no different OS to show in the menu, it's
> configured hidden to boot faster. If you want to discover the menu, you
> must hold [Shift] key at boot manager stage.

A bit confused here... are you talking about the Ubuntu boot option in 
GRUB? No, that in itself was/is(currently) fine and working. The menu 
I'm talking about is the BIOS boot device manager/window that comes up 
by entering BIOS Boot Options/holding F12 after POST. The entry to boot 
to "ubuntu"(The HDD where Ubuntu-Gnome is on) was gone, with only the 
HDD model(as mentioned previously) option remaining.

Attempting to boot to the HDD model option after "ubuntu" goes missing 
just boots to Windows. I'm guessing that is because it couldn't find an 
OS on the HDD so it went to my default boot option, which was my Windows 
7 HDD...

AFAIK, my install of Ubuntu-Gnome itself is fine. Every time I've 
reinstalled GRUB via boot-repair it always lets me boot back into the OS 
with no problems, but eventually goes missing again... even months later 

> El 28/03/16 a les 02:32, Ty Young ha escrit:
>> On 03/27/2016 04:24 AM, Narcis Garcia wrote:
>>> Do you want to use GRUB With or Without Windows?
>>> Then will you update-grub With or Without Windows HDD plugged?
>> Without. The test that I just did was without Windows, though normally
>> it is plugged in during updates.
>>> El 27/03/16 a les 00:26, Ty Young ha escrit:
>>>> Sent this earlier with an image attached but the size was too big and it
>>>> needed to be approved by a mod. I'll just include a link instead...
>>>> On 03/25/2016 03:40 AM, Narcis Garcia wrote:
>>>>> I suppose the only thing to seem disappeared is GRUB's menu (hidden to
>>>>> be more precise).
>>>>> If you already boot to GNU/Linux (Ubuntu), the command "update-grub"
>>>>> will rebuild menu's entries with plugged volumes that have operating
>>>>> systems.
>>>> I removed my Windows HDD and did update-grub and I can still boot into
>>>> Ubuntu Gnome. This is what it gave for output, if it helps any:
>>>>> El 25/03/16 a les 08:12, Ty Young ha escrit:
>>>>>> On 03/25/2016 01:58 AM, Tim wrote:
>>>>>>> On 25/03/16 17:12, Ty Young wrote:
>>>>>>>> I've personally never used update-grub before, so unless the command
>>>>>>>> was given by an update, no.
>>>>>>> Yes it will get triggered by system updates from time to time, so it
>>>>>>> would be worth trying and see if breaks things. A reproducible bug is
>>>>>>> much
>>>>>>> better than one that says "things break after a random reboot"!
>>>>>> Just update-grub? No special arguments/options? I'll try that tomorrow
>>>>>> and see what happens.
>>>>>> Yeah, sorry about that. I said that because I have no clue what
>>>>>> could be
>>>>>> causing it. I hadn't installed any grub updates in a long time and
>>>>>> I've
>>>>>> only recently upgraded the kernel to 4.5, the only times I would think
>>>>>> update-grub would run.
>>>>>> I swear this has happened without even installing updates before
>>>>>> though.
>>>>>> Guess I'll found out tomorrow when I run it...
>>>>>>>> I run Windows 7 and Ubuntu Gnome on separate hard drives. I had
>>>>>>>> unplugged the Windows 7 HDD for the boot-repair.
>>>>>>>> Don't think so since it happens when restarting from Ubuntu Gnome
>>>>>>>> and
>>>>>>>> never from Windows 7 to Ubuntu Gnome if the option was there before
>>>>>>>> restarting Ubuntu Gnome.
>>>>>>> OK, its probably not from windows then
>>>>>>>> If it matters any, I get a duplicate UEFI entry for Ubuntu, named
>>>>>>>> after the hard drive model(Model: ST3750528AS). If i select it, the
>>>>>>>> screen
>>>>>>>> flashes blue and enters grub as normal(or looks normal, anyway).
>>>>>>> I don't have any UEFI hardware still, so not entirely sure about
>>>>>>> this.
>>>>>>> But I believe the UEFI entries are added by the OS, maybe you can use
>>>>>>> efibootmgr to remove the dupe. No idea if this is causing your issues
>>>>>>> though.

More information about the Ubuntu-GNOME mailing list