3.19.x on xenial - out of date Ephy/Webkit and touchpad settings b0rked

Tim darkxst at fastmail.fm
Thu Mar 3 04:57:29 UTC 2016



On 03/03/16 14:59, Michael Gratton wrote:
> On Thu, Mar 3, 2016 at 12:36 PM, Michael Gratton <mike at vee.net> wrote:
>>
>>>>  Also, the touchpad settings in gnome-control-centre are being completely ignored. None of the UI elements relating to the touchpad seem to
>>>>  have any effect on my Macbook Pro's built-in touchpad, nor my external Apple Bluetooth touchpad. Natural scrolling is not getting enabled
>>>> when
>>>>  it set to On, Tap-to-click is not enabled when set or On, and disabling  the touchpad by setting it to Off does not work either. I don't know
>>>>  if this is related to the UI refresh or something else, any suggestions?
>>> I don't have a macbook, but I will take a quick look at this on my laptop and see if its the same, when I get a chance.
>>
>> That would be great, ta!
>
>
> After a bit of investigation, the problem doesn't occur under X11 when using libinput instead of synaptics/evdev as the input driver -
> removing xserver-xorg-input-synaptics and xserver-xorg-input-evdev, installing xserver-xorg-input-libinput and restarting my X session fixes it.
>
> Since using evdev/synaptics worked fine under Wiley with Mutter 3.18, I'm not sure if the problem is with changes to xorg/evdev/synaptics in
> Xenial or a bug in Mutter 3.19.
File a bug against mutter, I think 3.20 will need to be using libinput on X11 by default.

https://git.gnome.org/browse/gnome-settings-daemon/commit/?id=66c211ff24bec6a938d6a6a0dd8730f4689ef383https://git.gnome.org/browse/gnome-settings-daemon/commit/?id=66c211ff24bec6a938d6a6a0dd8730f4689ef383

>
> Any suggestions where I should report the bug?
>
> //Mike
>




More information about the Ubuntu-GNOME mailing list