3.19.x on xenial - out of date Ephy/Webkit and touchpad settings b0rked

Michael Gratton mike at vee.net
Wed Mar 2 06:37:53 UTC 2016


Hi all,

I just upgraded to Xenial and GNOME 3.19 from gnome3-staging, since I'm 
a bleeding-edge tragic. Most things look good, except that the old 
versions of Epiphany/WebKitGTK have some serious rendering problems and 
touchpad setting are being ignored.

The only packages available for Epiphany/WebKitGTK are out of date - 
2.18.x/2.10.x, and these seem to have theme issues - certain in-page 
text and button labels are not being rendered correctly, so they are 
not visible at all. This makes it pretty unusable. I'm attempting at 
the moment to build a deb of webkitgtk-2.11.91 so I can build Ephy 
3.19.x, to see if that fixes the problems.

Also, the touchpad settings in gnome-control-centre are being 
completely ignored. None of the UI elements relating to the touchpad 
seem to have any effect on my Macbook Pro's built-in touchpad, nor my 
external Apple Bluetooth touchpad. Natural scrolling is not getting 
enabled when it set to On, Tap-to-click is not enabled when set or On, 
and disabling  the touchpad by setting it to Off does not work either. 
I don't know if this is related to the UI refresh or something else, 
any suggestions?

Ta,
//Mike

--
⊨ Michael Gratton, Percept Wrangler.
⚙ <http://mjog.vee.net/>





More information about the Ubuntu-GNOME mailing list