GNOME ssh askpass not working in 3.20?

Paul Smith paul at
Sat Jun 11 16:31:53 UTC 2016

This morning I updated my Ubuntu GNOME 16.04 LTS system to GNOME 3.20
using the Gnome3 Staging PPA.

One issue is that somehow ssh is not longer asking for my passphrase
using ssh-askpass.  Instead it always asks on the terminal and I need to
enter it each time (it's not added to ssh-agent).  I didn't change
anything about my personal configuration except install the GNOME 3.20
packages and reboot.

If I run "ssh-add" by hand, then the key is added to the agent and it
works properly, so the agent is running and configured properly.  It's
only the ssh-askpass connection thing that is busted.

I've noticed that I don't have any SSH_ASKPASS env var set, but I don't
remember setting that myself before; also if I set it before starting
ssh (export SSH_ASKPASS=/usr/bin/ssh-askpass) I still get asked for the
passphrase on the terminal.

(Also if I run that ssh-askpass by hand I get a standard GNOME dialog,
instead of the normal modal dialog I used to get, which dimmed the
entire screen--maybe that's an Ubuntu extension?  I can't find other
askpass commands but maybe they have an unusual name?)

I find it odd that this is related to GNOME 3.20 install but I don't
know what else it could be since that's all I changed.

Anyone have any thoughts, or pointers to what I should look for?

More information about the Ubuntu-GNOME mailing list