Install Ubuntu Gnome on Ubuntu MATE

Akshit Sharma asagent7 at gmail.com
Thu Feb 4 05:00:47 UTC 2016


Hi all,

I managed to get gnome running.
However, its not running properly. Windows are closing when I click any
option on them. I think I might have some missing packages. Can you let me
know all the packages for which ubuntu-gnome has a dependency.

Thanks and Regards
Akshit Sharma

On Sat, Jan 30, 2016 at 10:58 PM, Akshit Sharma <asagent7 at gmail.com> wrote:

> Sorry for my long absence. Finally, I decided to remove all repos,
> gnome-shell, gnome-shell-externsions etc and begin with a clean slate.
>  I installed the ubuntu-gnome-desktop package and tried running gnome with
> both lightdm and gdm. It did not run and this was the log :
>
>
> (update-notifier:12243): Gtk-WARNING **: Theme parsing error:
> gtk-widgets.css:2:19: Theming engine 'adwaita' not found
>
> (update-notifier:12243): Gtk-WARNING **: Theme parsing error:
> gtk-widgets-3_10.css:12:16: Theming engine 'adwaita' not found
>
> (evolution-alarm-notify:12201): Gdk-WARNING **: evolution-alarm-notify:
> Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
>
> blueman-applet: Fatal IO error 11 (Resource temporarily unavailable) on X
> server :0.
>
> (update-notifier:12243): Gdk-WARNING **: update-notifier: Fatal IO error
> 11 (Resource temporarily unavailable) on X server :0.
>
>
> Received signal:15->'Terminated'
>
> Received signal:15->'Terminated'
> g_dbus_connection_real_closed: Remote peer vanished with error: Underlying
> GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
> gnome-session[3189]: WARNING: Could not parse desktop file
> caribou-autostart.desktop or it references a not found TryExec binary
> gnome-session[3189]: WARNING: Could not parse desktop file
> mate-user-share-obexftp.desktop or it references a not found TryExec binary
> gnome-session[3189]: WARNING: Could not parse desktop file
> unity-fallback-mount-helper.desktop or it references a not found TryExec
> binary
> gnome-session[3189]: WARNING: Could not parse desktop file
> unity-settings-daemon.desktop or it references a not found TryExec binary
> gnome-session[3189]: WARNING: Could not parse desktop file
> mate-user-share-webdav.desktop or it references a not found TryExec binary
> gnome-session[3189]: WARNING: Could not parse desktop file
> mate-user-share-obexpush.desktop or it references a not found TryExec binary
> gnome-session[3189]: WARNING: Could not parse desktop file
> gnome-sound-applet.desktop or it references a not found TryExec binary
> gnome-session[3189]: WARNING: Could not parse desktop file
> extras-indicator-brightness.desktop or it references a not found TryExec
> binary
> GNOME_KEYRING_CONTROL=/run/user/1000/keyring-pEKZrp
> GPG_AGENT_INFO=/run/user/1000/keyring-pEKZrp/gpg:0:1
> SSH_AUTH_SOCK=/run/user/1000/keyring-pEKZrp/ssh
> GNOME_KEYRING_CONTROL=/run/user/1000/keyring-pEKZrp
> GPG_AGENT_INFO=/run/user/1000/keyring-pEKZrp/gpg:0:1
> SSH_AUTH_SOCK=/run/user/1000/keyring-pEKZrp/ssh
> GNOME_KEYRING_CONTROL=/run/user/1000/keyring-pEKZrp
> GPG_AGENT_INFO=/run/user/1000/keyring-pEKZrp/gpg:0:1
> SSH_AUTH_SOCK=/run/user/1000/keyring-pEKZrp/ssh
> GNOME_KEYRING_CONTROL=/run/user/1000/keyring-pEKZrp
> GPG_AGENT_INFO=/run/user/1000/keyring-pEKZrp/gpg:0:1
> SSH_AUTH_SOCK=/run/user/1000/keyring-pEKZrp/ssh
>
> (gnome-shell:3232): Gtk-WARNING **: Theme parsing error:
> gtk-widgets.css:2:19: Theming engine 'adwaita' not found
>
> (gnome-shell:3232): Gtk-WARNING **: Theme parsing error:
> gtk-widgets-3_10.css:12:16: Theming engine 'adwaita' not found
>
> (gnome-shell:3232): libupower-glib-WARNING **: No 'CanSuspend' property
> Window manager warning: Log level 16: Theme parsing error:
> gtk-widgets.css:2:19: Theming engine 'adwaita' not found
> Window manager warning: Log level 16: Theme parsing error:
> gtk-widgets-3_10.css:12:16: Theming engine 'adwaita' not found
>
> (gnome-shell:3232): Gjs-WARNING **: JS ERROR: Error: Requiring Clutter,
> version 1.0: Typelib file for namespace 'Clutter', version '1.0' not found
> @/usr/share/gnome-shell/js/ui/environment.js:9
> @<main>:1
>
> Window manager warning: Log level 32: Execution of main.js threw
> exception: JS_EvaluateScript() failed
> gnome-session[3189]: WARNING: App 'gnome-shell.desktop' exited with code 1
>
> (gnome-shell:3252): Gtk-WARNING **: Theme parsing error:
> gtk-widgets.css:2:19: Theming engine 'adwaita' not found
>
> (gnome-shell:3252): Gtk-WARNING **: Theme parsing error:
> gtk-widgets-3_10.css:12:16: Theming engine 'adwaita' not found
>
> (gnome-shell:3252): libupower-glib-WARNING **: No 'CanSuspend' property
> Window manager warning: Log level 16: Theme parsing error:
> gtk-widgets.css:2:19: Theming engine 'adwaita' not found
> Window manager warning: Log level 16: Theme parsing error:
> gtk-widgets-3_10.css:12:16: Theming engine 'adwaita' not found
>
> (gnome-shell:3252): Gjs-WARNING **: JS ERROR: Error: Requiring Clutter,
> version 1.0: Typelib file for namespace 'Clutter', version '1.0' not found
> @/usr/share/gnome-shell/js/ui/environment.js:9
> @<main>:1
>
> Window manager warning: Log level 32: Execution of main.js threw
> exception: JS_EvaluateScript() failed
> gnome-session[3189]: WARNING: App 'gnome-shell.desktop' exited with code 1
> gnome-session[3189]: WARNING: App 'gnome-shell.desktop' respawning too
> quickly
> gnome-session[3189]: CRITICAL: We failed, but the fail whale is dead.
> Sorry....
>
> (xdg-user-dirs-gtk-update:3263): Gtk-WARNING **: Theme parsing error:
> gtk-widgets.css:2:19: Theming engine 'adwaita' not found
>
> (xdg-user-dirs-gtk-update:3263): Gtk-WARNING **: Theme parsing error:
> gtk-widgets-3_10.css:12:16: Theming engine 'adwaita' not found
>
> (nvidia-settings:3267): Gtk-WARNING **: Theme parsing error:
> gtk-widgets.css:2:19: Theming engine 'adwaita' not found
>
> (nvidia-settings:3267): Gtk-WARNING **: Theme parsing error:
> gtk-widgets-3_10.css:12:16: Theming engine 'adwaita' not found
>
> ** (process:3284): CRITICAL **: bluez.vala:104:
> GDBus.Error:org.bluez.Error.NoSuchAdapter: No such adapter
> (uint32 1,)
> Loading configuration plugins
> blueman-applet version 1.23 starting
> Stale PID, overwriting
> Using gconf config backend
> Using gconf config backend
> Using gconf config backend
> libmediaart-Message: Initializing Storage...
> libmediaart-Message: Mount monitors set up for to watch for added, removed
> and pre-unmounts...
> libmediaart-Message: No mounts found to iterate
> Using gconf config backend
> Using gconf config backend
> Using gconf config backend
> Using gconf config backend
> Using gconf config backend
> Using gconf config backend
> Using gconf config backend
> Using gconf config backend
>
> (gnome-user-share:3364): Gtk-WARNING **: Theme parsing error:
> gtk-widgets.css:2:19: Theming engine 'adwaita' not found
>
> (gnome-user-share:3364): Gtk-WARNING **: Theme parsing error:
> gtk-widgets-3_10.css:12:16: Theming engine 'adwaita' not found
>
> (evolution-alarm-notify:3404): Gtk-WARNING **: Theme parsing error:
> gtk-widgets.css:2:19: Theming engine 'adwaita' not found
>
> (evolution-alarm-notify:3404): Gtk-WARNING **: Theme parsing error:
> gtk-widgets-3_10.css:12:16: Theming engine 'adwaita' not found
>
> (update-notifier:3555): Gtk-WARNING **: Theme parsing error:
> gtk-widgets.css:2:19: Theming engine 'adwaita' not found
>
> (update-notifier:3555): Gtk-WARNING **: Theme parsing error:
> gtk-widgets-3_10.css:12:16: Theming engine 'adwaita' not found
> blueman-applet: Fatal IO error 11 (Resource temporarily unavailable) on X
> server :0.
>
> (evolution-alarm-notify:3404): Gdk-WARNING **: evolution-alarm-notify:
> Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
>
>
> Received signal:15->'Terminated'
>
> Received signal:15->'Terminated'
> g_dbus_connection_real_closed: Remote peer vanished with error: Underlying
> GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
>
> What to do now?
>
> On Tue, Dec 29, 2015 at 10:21 AM, Akshit Sharma <asagent7 at gmail.com>
> wrote:
>
>> @Narcis No, I didn't exclude any package.
>>
>> On Mon, Dec 28, 2015 at 2:13 PM, Narcis Garcia <informatica at actiu.net>
>> wrote:
>>
>>> I was asking about, when you installed the packages, if you didn't
>>> install gdm, and if you explicitly excluded recommended packages.
>>>
>>>
>>> El 27/12/15 a les 18:20, Akshit Sharma ha escrit:
>>> > @Tim That particular package is installed. I will try with the
>>> > accessibility themes and tell.
>>> > @Narcis I didn't get what you said Can you explain it more?
>>> >
>>> > On Sun, Dec 27, 2015 at 2:30 PM, Narcis Garcia <informatica at actiu.net
>>> > <mailto:informatica at actiu.net>> wrote:
>>> >
>>> >     Did you exclude "recommends" dependencies or gdm?
>>> >
>>> >     El 26/12/15 a les 07:55, Tim ha escrit:
>>> >     > This is likely your issue, you should check if that is installed!
>>> >     >
>>> >     > On 26/12/15 17:31, Akshit Sharma wrote:
>>> >     >> /usr/bin/gnome-shell: error while loading shared libraries:
>>> libmozjs-24.so.0: cannot open shared object file: No such file or directory
>>> >     >
>>> >     >
>>> >
>>> >     --
>>> >     Ubuntu-GNOME mailing list
>>> >     Ubuntu-GNOME at lists.ubuntu.com <mailto:
>>> Ubuntu-GNOME at lists.ubuntu.com>
>>> >     Modify settings or unsubscribe at:
>>> >     https://lists.ubuntu.com/mailman/listinfo/ubuntu-gnome
>>> >
>>> >
>>>
>>> --
>>> Ubuntu-GNOME mailing list
>>> Ubuntu-GNOME at lists.ubuntu.com
>>> Modify settings or unsubscribe at:
>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-gnome
>>>
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-gnome/attachments/20160204/11fbf80b/attachment.html>


More information about the Ubuntu-GNOME mailing list