Booting into busybox

Narcis Garcia informatica at actiu.net
Sun Oct 25 08:26:55 UTC 2015


I recommend you to to try*:

1. Boot from Live CD/USB
2. Perform a memory test (boot menu)
3. IF memtest completed clean, then boot again with Live CD/USB
4. +IF target partition (/dev/sda1?) is mountable, THEN:
4.1. Make a complete backup of all directories & files
4.2. Run a complete reparation**: fsck -cy /dev/sda1
4.3. Make a second backup of all directories & files repaired

After fsck check, you can ask how many bad blocks were marked:
dumpe2fs -b /dev/sda1 2>&1 | grep -ive 'dumpe2fs' | wc -l

(*) This recipe (as other procedures) can loss your data. I cannot sure
you this procedure as valid without having direct access to computer.

(**) -cy perfoms a read only check. To perform a read&write check you
can use -ccy (even more long in hours)


El 25/10/15 a les 08:54, Tim ha escrit:
> 
> 
> On 25/10/15 10:55, Andrés Muñiz Piniella wrote:
>> El 24 de octubre de 2015 16:07:40 GMT+01:00, "Andrés Muñiz Piniella" <a75576 at alumni.tecnun.es> escribió:
>>> El 23 de octubre de 2015 20:31:29 GMT+01:00, "Andrés Muñiz Piniella"
>>> <a75576 at alumni.tecnun.es> escribió:
>>>>
>>>> El 11 de octubre de 2015 14:02:52 GMT+01:00, Erick Brunzell
>>>> <lbsolost at yahoo.com> escribió:
>>>>> On 10/11/2015 03:52 AM, Andrés Muñiz Piniella wrote:
>>>>>> Hello,
>>>>>> After grub and after ubuntu gnome splash screen it just loads into
>>>>> something called busybox. I then typed the command exit and it gives
>>> a
>>>>> series of messages but does not shutdown (should it shutdown?)
>>>>>> I force reboot and force shutdown with the buttons on the hardware.
>>>>> Same result.
>>>>>> I tried loading previous kernel versions (.45?) With similar
>>>> results.
>>>>>> I am using LTS version.
>>>>>>
>>>>>> Please let me know what details are needed(I will probably need to
>>>>> take pictures of the screen) to get this up and running. Thanks!
>>>>>> Regards,
>>>>>> Andrés
>>>>>>
>>>>>>
>>>>>>
>>>>> If you are able to boot a live DVD/USB I'd run the filesystem check 
>>>>> offered by Gparted on only your Linux partitions. Do not perform any 
>>>>> other partition manipulations to avoid possible data loss! I'm
>>>>> attaching 
>>>>> a screenshot of Gparted just as an example. In that example I 
>>>>> right-clicked on /dev/sda1 to display the function menu. When the 
>>>>> filesystem check is complete you'll be able to view the results and
>>>> see
>>>>> if any errors were fixed or still persist.
>>>>>
>>>>> Lance
>>>> Finally got hold of a live CD.
>>>> Thanks Lance! No errors found.
>>>>
>>>> Why else would this come up?
>>> Hi all,
>>>
>>> Looked up and found SMART(montools).  See here output of smart.
>>>
>>> http://paste2.org/Z6LXxgP5
>>>
>>> Looks like some sectors are broken?
>>>
>>> Is this when I use dd-rescue?
>>>
>>> Now gparted does not even recognize it as a ext4 just as unknown. 
>>>
>>> I ran boot-repair and now grub only sees my other partition. Running an
>>> installation of bodhi linux I thought did not exist.
>> A bit of an update I ran fsck and it seemed to fix some stuff and I managed to see some of the Ubuntu-gnome instalation files from my other partition. Helped me do som minor backup.
>>
>> I did a grub update, 
>> I then tried to boot into Ubuntu gnome
>>
>> Some pictures of the commands I tried:
>>
>> https://my.owndrive.com/index.php/s/oU4tCqFjlLP11Ac
>>
>> https://my.owndrive.com/index.php/s/9XbnCxaYHgAwP9G
>>
>> https://my.owndrive.com/index.php/s/aoeeTyhdOdODVdx
>>
>> Seems that I can do updates it is just not mounted? Can't reboot properly.
>>
>> Any pointers will be helpful.
> Your partition is mounted read-only by the looks of it.
>>
> 
> 



More information about the Ubuntu-GNOME mailing list