Super+o shortcut taken by Gnome process

Bruce Pieterse dev at
Wed Aug 5 20:39:42 UTC 2015

On 03/08/2015 21:31, Thomas SIMON wrote:
> Dear all,
> I've been following this list a bit and I hope I'm not at the wrong
> place by asking for a bit of help on something that I think is specific
> to Ubuntu GNOME (for Ubuntu there are several mailing lists and this
> mailing list says support too!). I've posted a question a week ago on
> askubuntu but haven't had an answer yet. Basically, I would like to
> assign the Super+O shortcut to a script (because a side-button of my
> computer is oddly mapped to Super+O) but it seems a Gnome process
> intercepts it. I've arrived to this conclusion because:
> - Using xev within a terminal in the graphical session shows
> KeymapNotify event and doesn't show keycode.
> - Using xev within xterm launched from a console session shows the
> expected keycodes (for super key & o key)
> - Booting using Ubuntu GNOME live CD has the same issues (shortcut
> Super+O cannot be used)
> - Booting using Ubuntu live CD doesn't have the issue (xev shows the
> expected keycodes & I can attribute Super+O shortcut to stuff, I tested
> with launching the help browser)
> I've gone through all I could think off (de-activating all shell
> extensions, extracting all shortcuts with a script given on askubuntu
> that's meant to be used for backing up shortcuts and manually going
> through dconf-editor at all places where shortcuts are) without finding
> what could use this shortcut. Maybe the answer is quite easy and I'm
> missing something. 
> The only reference I've found is the following is on a Fedora website (I
> don't know if we can post URL here) where it says that it's to lock
> screen orientation (which ironically is what I would like to do but
> using scripts since the screen doesn't rotate automatically) but there's
> no reference to where it's defined.
> Perhaps something a bit similar but shift+LaunchA shortcut works while
> only LaunchA doesn't and I also cannot find LaunchA registered anywhere.
> If this isn't the place to ask such a question, apologies!
> Regards,
> Thomas

Hi Thomas,

I've tried the above in Gnome 3.16 with wily and I get the same result.
Please can you file a new bug report here:

Your original e-mail can be used as the bug description.

I tried the above with a simple script that sends "test" to notify-send.
Using a command instead: /usr/bin/notify-send Test doesn't work. I can't
see any existing bindings for Super+O either.


All the best,


More information about the Ubuntu-GNOME mailing list