je viens de regarder dans Firefox et &quot;about:plugins&quot; j&#39;ai &quot;Shockwave Flash 9.0 r999&quot; et non &quot;Shockwave Flash 10.0 r32&quot; ce qui pousserait à pense que je n&#39;ai pas la bonne version.Et bien là je je serais ravis que tu me précise comme modifier ça.<br>
Merci.<br>
<br><br><div class="gmail_quote">Le 8 novembre 2009 03:35, Avell Diroll <span dir="ltr">&lt;<a href="mailto:avelldiroll@gmail.com">avelldiroll@gmail.com</a>&gt;</span> a écrit :<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="im">Séb wrote:<br>
&gt; Ce dont je suis sûr, c&#39;est qu&#39;il n&#39;y a pas de bugs ou de problèmes dans<br>
&gt; les paquets liés au plugin flash.<br>
&gt; Si quelqu&#39;un d&#39;autre sur la liste à une idée... Moi je suis à court!<br>
<br>
</div>99% des problèmes de flash sous ubuntu sont liés à ce qui à été tenté<br>
avant l&#39;installation correcte (i.e. installer flashplugin-installer qui<br>
télécharge le bon plugin puis build et installe un paquet du nom de<br>
flashplugin-nonfree, il installe également un wrapper sur les systèmes<br>
64bits).<br>
<br>
En effet les autres paquets fournissant un support pour flash peuvent<br>
interférer, il faut donc les désinstaller:<br>
gnash<br>
gnash-common<br>
gnash-cygnal<br>
gnash-tools<br>
konqueror-plugin-gnash<br>
mozilla-plugin-gnash<br>
libswfdec-0.6-90<br>
libswfdec-0.6-90-dbg<br>
libswfdec-0.6-dev<br>
libswfdec-0.7-1<br>
libswfdec-0.7-1-dbg<br>
libswfdec-0.7-dev<br>
libswfdec-0.8-0<br>
libswfdec-0.8-0-dbg<br>
libswfdec-0.8-dev<br>
libswfdec-dev<br>
swfdec-gnome<br>
swfdec-mozilla<br>
adobe-flashplugin (fonctionnel mais suis le développement de flash de<br>
beaucoup moins près que flashplugin-installer)<br>
<br>
Pour vérifier quels plugins sont disponibles sur le système, il suffit<br>
de faire les deux commandes suivantes:<br>
update-alternatives --list mozilla-flashplugin<br>
update-alternatives --list firefox-flashplugin<br>
qui devraient lister chacune une seule ligne:<br>
/usr/lib/flashplugin-installer/libflashplayer.so<br>
<br>
Si il y en a plusieurs (reste de config précédente ou erreurs), il faut<br>
sélectionner le bon plugin à l&#39;aide des commandes:<br>
sudo update-alternatives --config mozilla-flashplugin<br>
sudo update-alternatives --config firefox-flashplugin<br>
<br>
Enfin si il y a toujours des soucis, il faut vérifier que la page<br>
about:plugins de firefox indique bien les lignes:<br>
  Shockwave Flash<br>
     File name: libflashplayer.so<br>
<div class="im">     Shockwave Flash 10.0 r32<br>
<br>
</div>Si ce n&#39;est pas le cas, flash à probablement été installé manuellement<br>
par le passé, le système de gestion des paquet ne peut pas le deviner.<br>
J&#39;en profite pour rappeler qu&#39;il faut toujours noter les manipulations<br>
effectuées à la main (i.e. dès que l&#39;on sort de l&#39;installation de paquet<br>
et de l&#39;édition d&#39;un fichier de config (/etc)), et le mentionner quand<br>
on pose des questions sur le sujet par la suite. Il faut donc retirer<br>
manuellement les fichiers installés précédemment. Attention cependant,<br>
comme dans toute manipulation &quot;manuelle&quot;, il est important de comprendre<br>
ce que l&#39;on fait. Les fichiers en questions se trouvent probablement<br>
dans les dossiers suivant (attention à ne pas supprimer de fichiers ne<br>
concernant pas flash):<br>
$HOME/.mozilla/plugins/<br>
/usr/lib/mozilla/plugins/ (ne pas retirer flashplugin-alternative.so !)<br>
/usr/lib/firefox/plugins/ (ne pas retirer flashplugin-alternative.so !)<br>
/usr/lib/firefox-3.5.4/plugins/<br>
(il y a peut être des libraries qui traînent également dans /usr/lib32)<br>
<br>
<br>
Bien sûr après chaque manipulation censée régler le problème, il faut<br>
relancer firefox afin de tester le fonctionnement de flash.<br>
<br>
Par ailleurs le plugin flash d&#39;adobe en version 64bits vient de passer<br>
en alpha2. Pour ceux qui veulent l&#39;installer à la main, il se trouve ici:<br>
<a href="http://labs.adobe.com/downloads/flashplayer10.html" target="_blank">http://labs.adobe.com/downloads/flashplayer10.html</a><br>
plus d&#39;information ici:<br>
<a href="http://doc.ubuntu-fr.org/flashplayer#installation_de_flash_player_10_flash_version_64_bits" target="_blank">http://doc.ubuntu-fr.org/flashplayer#installation_de_flash_player_10_flash_version_64_bits</a><br>
<br>
Enfin, ce n&#39;est pas en &quot;bottant le *** aux devs&quot; comme j&#39;ai pu le lire<br>
dernièrement dans ce fil que l&#39;on fait avancer les choses :/<br>
Au lieu de se plaindre, la démarche efficace est de remplir un bug<br>
report et suivre son développement en y contribuant un maximum de<br>
détails! De plus il ne faut pas oublier que flash est un logiciel<br>
propriétaire ce qui est la source de tous ces désagréments de<br>
configuration. Autant aller réclamer la libération du code à adobe et de<br>
suggérer aux sites utilisés ne pas se servir de flash plutôt que de s&#39;en<br>
prendre au devs ...<br>
<br>
En attendant la mise en œuvre de HTML5 ...<br>
<br>
Bonne continuation<br>
<br>
Ju<br>
<font color="#888888">--<br>
Those that would trade liberty for security deserve neither.<br>
</font><div><div></div><div class="h5"><br>
--<br>
ubuntu-fr mailing list<br>
<a href="mailto:ubuntu-fr@lists.ubuntu.com">ubuntu-fr@lists.ubuntu.com</a><br>
<a href="https://lists.ubuntu.com/mailman/listinfo/ubuntu-fr" target="_blank">https://lists.ubuntu.com/mailman/listinfo/ubuntu-fr</a><br>
</div></div></blockquote></div><br><br clear="all"><br>-- <br>Central Banlieue<br><br>rapidité, efficacité, résultat<br><br>Le système génial c&#39;est UBUNTU  Jaunty et maintenant Karmic super génial<br><br>Vive LINUX et la liberté du libre<br>