Bonjour,<br><br>Je suis l&#39;auteur d&#39;un programme écrit en Qt4 (<a href="http://doc.ubuntu-fr.org/qmagneto">http://doc.ubuntu-fr.org/qmagneto</a>) . Il utilise notamment sqlite. Dans la version Intrepid, un paquet nommé libqt4-sql-sqlite est nécessaire et doit apparaître dans la ligne Depends du fichier debian/control. Dans la version Hardy, ce paquet n&#39;existe pas et ne doit pas apparaître dans les dépendances. Alors comment faire pour rendre cette dépendance nécessaire uniquement pour Intrepid? Je cherche une solution me permettant de garder un unique répertoire debian. L&#39;idéal serait de construire en une seule commande &quot;dpkg-buildpackage&quot; les paquets pour Hardy et Intrepid avec chacun les bonnes dépendances. Autre solution &quot;idéale&quot; serait un seul paquet avec des dépendances adaptées en fonction de la distribution. Mais tout cela est-il possible?<br>
<br>Merci<br>