<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:times new roman,new york,times,serif;font-size:12pt"><div>Merci, je vais essayer ça, je suppose que la plupart des nouvelles distributions utilisent xorg <br></div><div style="font-family: times new roman,new york,times,serif; font-size: 12pt;"><br><div style="font-family: arial,helvetica,sans-serif; font-size: 10pt;">----- Message d'origine ----<br>De : Sébastien / Seb-bubuntu &lt;seb.bubuntu@gmail.com&gt;<br>À : Tahar &lt;tahar_ba@yahoo.fr&gt;<br>Cc : Ubuntu &lt;ubuntu-fr@lists.ubuntu.com&gt;<br>Envoyé le : Vendredi, 18 Juillet 2008, 11h16mn 29s<br>Objet&nbsp;: Re: Re : Etat du serveur X (Ex detecter le browser par défaut)<br><br>-----BEGIN PGP SIGNED MESSAGE-----<br>Hash: SHA1<br><br>Tahar wrote:<br>&gt; Je me réponds à moi même :)<br>&gt; <br>&gt; Pour x-www-browser, ça résout mon problème, par contre pour init 5 déjà<br>&gt; sous
 Ubuntu, le niveau init pour l'interface graphique est le niveau 2<br>&gt; donc je ne peux pas compter sur runlevel<br>&gt; <br>&gt; Des suggestions ?<br>&gt; <br>&gt; Merci<br><br>Salut,<br><br>pourquoi pas bêtement "ps -A | grep Xorg"?<br>si le retour est vide c'est qu'aucun processus Xorg ne tourne... et donc pas de serveur X!<br>Petite illustration...<br>Sur mon portable (Ubuntu 8.04, sous Gnome donc):<br><br>~$ ps -A | grep Xorg<br> 6333 tty7&nbsp; &nbsp;  00:03:06 Xorg<br> 6550 tty7&nbsp; &nbsp;  00:00:00 Xorg<br>~$<br><br>Sur mon serveur (Ubuntu serveur 8.04, pas de serveur graphique):<br>~$ ps -A | grep Xorg<br>~$<br><br>Evidemment, il faut que le serveur graphique soit Xorg...<br><br>Séb<br>-----BEGIN PGP SIGNATURE-----<br>Version: GnuPG v1.4.6 (GNU/Linux)<br>Comment: Using GnuPG with Mozilla - <a href="http://enigmail.mozdev.org"
 target="_blank">http://enigmail.mozdev.org</a><br><br>iD8DBQFIgF9tlabueleSRzIRAkieAKD6HCa1CYaeplceIEq3yNOFsSgY/ACg2iOc<br>vOsvIojvydJiJfQ0ReZ/QTY=<br>=qIA5<br>-----END PGP SIGNATURE-----<br></div></div></div></body></html>