<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
<br>
<br>
<br>
suite&nbsp; <br>
exemple<br>
<br>
<br>
1.1. Ethernet<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; La plus grande partie de la configuration d'ethernet est dans
un seul fichier :<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; /etc/network/interfaces. Si vous n'avez pas de p&eacute;riph&eacute;rique
ethernet, seule l'interface<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; de boucle locale sera dans ce fichier, qui ressemblera &agrave; ceci :<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; # This file describes the network interfaces available on your
system<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; # and how to activate them. For more information, see
interfaces(5).<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; # The loopback network interface<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; auto lo<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; iface lo inet loopback<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; address 127.0.0.1<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; netmask 255.0.0.0<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<b> Si vous n'avez qu'un p&eacute;riph&eacute;rique, eth0, qu'il obtient sa
configuration depuis un serveur<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; DHCP et qu'il doit &ecirc;tre activ&eacute; au d&eacute;marrage, seulement 2 lignes
suppl&eacute;mentaires sont<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; n&eacute;cessaires :<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; auto eth0<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; iface eth0 inet dhcp</b><br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; La premi&egrave;re ligne pr&eacute;cise que le p&eacute;riph&eacute;rique doit &ecirc;tre
automatiquement activ&eacute; au<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; d&eacute;marrage. La deuxi&egrave;me ligne pr&eacute;cise que cette interface (&laquo;
iface &raquo;) eth0 doit avoir un<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; adressage IPv4 (remplacer &laquo; inet &raquo; par &laquo; inet6 &raquo; pour un
p&eacute;riph&eacute;rique IPv6) et qu'elle<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; doit &ecirc;tre configur&eacute;e automatiquement par DHCP. En supposant que
votre r&eacute;seau et<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; votre serveur DHCP sont correctement configur&eacute;s, vous ne
devriez pas avoir besoin de<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; configuration suppl&eacute;mentaire. Le serveur DHCP fournira la
passerelle par d&eacute;faut (via la<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; comande route), l'adresse IP du p&eacute;riph&eacute;rique (via la commande
ifconfig), et les serveurs<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; DNS (dans le fichier /etc/resolv.conf).<br>
<br>
Philbur<br>
<br>
<br>
<br>
<br>
Nicolas Geraud a &eacute;crit&nbsp;:
<blockquote
 cite="mid355856040609051257u4993a32ajd92eae1cd98515fe@mail.gmail.com"
 type="cite">Pardon pour le retard de ma reponse, bcp de boulot.<br>
  <br>
Francois&gt; Hello, &eacute;tant en DHCP, je n'ai aucune ip a pr&eacute;ciser, c a ma
machine de lancer une requete en broadcast pour recuperer son ip<br>
  <br>
Philbur&gt; ces infos concernent le wifi et je suis en filaire. J'ai
regarde tout de mm mais je ne vois rien ressemblant a mon soucis.
  <br>
  <br>
Sinon je viens de constater, en lancant l'outil graphique
network-admin, que le p&eacute;riph&eacute;rique par d&eacute;faut de la passerelle est vide
lorsque ma connexion ne fonctionne pas.<br>
J'ai tent&eacute; de selectionner eth0 ds la combo mais ca n'a rien chang&eacute;.
  <br>
Un petit coup de ifdown/ifup, je relance network-admin, et la je vois
bien eth0 selectionn&eacute; ds la combo.<br>
  <br>
Savez comment fixer ca?<br>
  <br>
merci<br>
  <br>
  <br>
  <div><span class="gmail_quote">Le 31/08/06, <b
 class="gmail_sendername">Philbur</b> &lt;<a
 href="mailto:philbur@worldcom.ch" target="_blank"
 onclick="return top.js.OpenExtLink(window,event,this)">philbur@worldcom.ch</a>&gt;
a &eacute;crit :</span>
  <blockquote class="gmail_quote"
 style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">RE
HELP ! &lt;<a href="https://help.ubuntu.com/community/WIfiDocs/"
 target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">https://help.ubuntu.com/community/WIfiDocs/</a>&gt;<br>
    <br>
Philbur<br>
    <br>
Nicolas Geraud a &eacute;crit :
    <br>
&gt; Bonjour &agrave; tous.<br>
&gt;<br>
&gt; Depuis peu j'ai reconfigur&eacute; ma freebox pour qu'elle fasse office
de
    <br>
&gt; serveur DHCP tout en donnant une association IP fixe / @ mac aux<br>
&gt; machines de mon sous-r&eacute;seau.<br>
&gt;<br>
&gt; Mais depuis ce changement, lors de la majorit&eacute; de mes boots, je
n'ai<br>
&gt; pas de r&eacute;seau (mais eth0 est bien mont&eacute;).
    <br>
&gt;<br>
&gt; je dois donc faire un petit coup de :<br>
&gt; $&gt; sudo ifdown eth0<br>
&gt; $&gt; sudo ifup eth0<br>
&gt;<br>
&gt;<br>
&gt; quelqu'un aurait il une piste?<br>
&gt;<br>
&gt; Pour info :<br>
&gt;<br>
&gt; ~% cat /etc/network/interfaces
    <br>
&gt; auto lo<br>
&gt; iface lo inet loopback<br>
&gt;<br>
&gt; auto eth0<br>
&gt; iface eth0 inet dhcp<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; merci<br>
    <br>
  </blockquote>
  </div>
  <br>
</blockquote>
<br>
</body>
</html>