Salut,<br>j'avais déjà donné quelques infos, les revoici <br><br><span style="text-decoration: underline;"><font size="4"><span style="font-weight: bold;"><span style="text-decoration: underline;"><span style="font-weight: bold;">
J</span></span>e viens de booter, j'ai pas de réseau voici les commandes :</span></font><br><br></span><span style="font-weight: bold;">21:10 mulot@bunty ~%</span> cat /etc/network/interfaces<br>auto lo<br>iface lo inet loopback
<br><br>auto eth0<br>iface eth0 inet dhcp<br><br><span style="font-weight: bold;">21:10 mulot@bunty ~%</span> ifconfig<br>eth0&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Lien encap:Ethernet&nbsp; HWaddr XX:XX:XX:XX:XX:XX<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; adr inet6: fe80::211:2fff:feba:5c56/64 Scope:Lien
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; UP BROADCAST RUNNING MULTICAST&nbsp; MTU:1500&nbsp; Metric:1<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Packets reçus:0 erreurs:0 :0 overruns:0 frame:0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; TX packets:6 errors:0 dropped:0 overruns:0 carrier:0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; collisions:0 lg file transmission:1000
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Octets reçus:0 (0.0 b) Octets transmis:468 (468.0 b)<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Interruption:185 Adresse de base:0xc000<br><br>lo&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Lien encap:Boucle locale<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; inet adr:<a href="http://127.0.0.1">127.0.0.1</a>
&nbsp; Masque:<a href="http://255.0.0.0">255.0.0.0</a><br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; adr inet6: ::1/128 Scope:Hôte<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; UP LOOPBACK RUNNING&nbsp; MTU:16436&nbsp; Metric:1<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Packets reçus:624 erreurs:0 :0 overruns:0 frame:0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; TX packets:624 errors:0 dropped:0 overruns:0 carrier:0
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; collisions:0 lg file transmission:0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Octets reçus:241805 (236.1 KiB) Octets transmis:241805 (236.1 KiB)<br><br><font style="font-weight: bold;" size="4"><br></font><span style="text-decoration: underline;">
<font style="font-weight: bold;" size="4">Donc pour corriger tout ca je fais ce qui suit :</font><br><br></span><span style="font-weight: bold;">21:10 mulot@bunty ~%</span> sudo ifdown eth0<br>Password:<br>Internet Systems Consortium DHCP Client 
V3.0.3<br>Copyright 2004-2005 Internet Systems Consortium.<br>All rights reserved.<br>For info, please visit <a href="http://www.isc.org/products/DHCP">http://www.isc.org/products/DHCP</a><br><br>Listening on LPF/eth0/XX:XX:XX:XX:XX:XX
<br>Sending on&nbsp;&nbsp; LPF/eth0/XX:XX:XX:XX:XX:XX<br>Sending on&nbsp;&nbsp; Socket/fallback<br>DHCPRELEASE on eth0 to <a href="http://192.168.0.254">192.168.0.254</a> port 67<br><br><span style="font-weight: bold;">21:11 mulot@bunty ~%</span>
 sudo ifup eth0<br>Internet Systems Consortium DHCP Client V3.0.3<br>Copyright 2004-2005 Internet Systems Consortium.<br>All rights reserved.<br>For info, please visit <a href="http://www.isc.org/products/DHCP">http://www.isc.org/products/DHCP
</a><br><br>Listening on LPF/eth0/XX:XX:XX:XX:XX:XX<br>Sending on&nbsp;&nbsp; LPF/eth0/XX:XX:XX:XX:XX:XX<br>Sending on&nbsp;&nbsp; Socket/fallback<br>DHCPDISCOVER on eth0 to <a href="http://255.255.255.255">255.255.255.255</a> port 67 interval 6
<br>DHCPOFFER from <a href="http://192.168.0.254">192.168.0.254</a><br>DHCPREQUEST on eth0 to <a href="http://255.255.255.255">255.255.255.255</a> port 67<br>DHCPACK from <a href="http://192.168.0.254">192.168.0.254</a><br>
bound to <a href="http://192.168.0.1">192.168.0.1</a> -- renewal in 374600 seconds.<br><br><span style="font-weight: bold;">21:11 mulot@bunty ~%</span> ifconfig<br>eth0&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Lien encap:Ethernet&nbsp; HWaddr XX:XX:XX:XX:XX:XX<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; inet adr:<a href="http://192.168.0.1">192.168.0.1</a>&nbsp; Bcast:<a href="http://192.168.0.255">192.168.0.255</a>&nbsp; Masque:<a href="http://255.255.255.0">255.255.255.0</a><br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; adr inet6: fe80::211:2fff:feba:5c56/64 Scope:Lien
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; UP BROADCAST RUNNING MULTICAST&nbsp; MTU:1500&nbsp; Metric:1<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Packets reçus:80 erreurs:0 :0 overruns:0 frame:0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; TX packets:104 errors:0 dropped:0 overruns:0 carrier:0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; collisions:0 lg file transmission:1000
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Octets reçus:15188 (14.8 KiB) Octets transmis:11638 (11.3 KiB)<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Interruption:185 Adresse de base:0xc000<br><br>lo&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Lien encap:Boucle locale<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; inet adr:<a href="http://127.0.0.1">
127.0.0.1</a>&nbsp; Masque:<a href="http://255.0.0.0">255.0.0.0</a><br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; adr inet6: ::1/128 Scope:Hôte<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; UP LOOPBACK RUNNING&nbsp; MTU:16436&nbsp; Metric:1<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Packets reçus:1038 erreurs:0 :0 overruns:0 frame:0
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; TX packets:1038 errors:0 dropped:0 overruns:0 carrier:0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; collisions:0 lg file transmission:0<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Octets reçus:404477 (394.9 KiB) Octets transmis:404477 (394.9 KiB)<br><br><br>Voilou, tout m'a pourtant l'air correctement configuré ...
<br><br><br><div><span class="gmail_quote">Le 06/09/06, <b class="gmail_sendername">Philbur</b> &lt;<a href="mailto:philbur@worldcom.ch">philbur@worldcom.ch</a>&gt; a écrit :</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div>


  
  

<div bgcolor="#ffffff" text="#000000">
<br>
<br>
<br>
suite&nbsp; <br>
exemple<br>
<br>
<br>
1.1. Ethernet<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; La plus grande partie de la configuration d'ethernet est dans
un seul fichier :<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; /etc/network/interfaces. Si vous n'avez pas de périphérique
ethernet, seule l'interface<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; de boucle locale sera dans ce fichier, qui ressemblera à ceci :<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; # This file describes the network interfaces available on your
system<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; # and how to activate them. For more information, see
interfaces(5).<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; # The loopback network interface</div><div><span class="q"><br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; auto lo<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; iface lo inet loopback<br></span></div><div>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; address <a href="http://127.0.0.1" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">127.0.0.1</a><br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; netmask <a href="http://255.0.0.0" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">255.0.0.0</a><br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<b> Si vous n'avez qu'un périphérique, eth0, qu'il obtient sa
configuration depuis un serveur<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; DHCP et qu'il doit être activé au démarrage, seulement 2 lignes
supplémentaires sont<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; nécessaires :</b></div><div><span class="q"><b><br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; auto eth0<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; iface eth0 inet dhcp</b></span></div><div><br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; La première ligne précise que le périphérique doit être
automatiquement activé au<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; démarrage. La deuxième ligne précise que cette interface («
iface ») eth0 doit avoir un<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; adressage IPv4 (remplacer « inet » par « inet6 » pour un
périphérique IPv6) et qu'elle<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; doit être configurée automatiquement par DHCP. En supposant que
votre réseau et<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; votre serveur DHCP sont correctement configurés, vous ne
devriez pas avoir besoin de<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; configuration supplémentaire. Le serveur DHCP fournira la
passerelle par défaut (via la<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; comande route), l'adresse IP du périphérique (via la commande
ifconfig), et les serveurs<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; DNS (dans le fichier /etc/resolv.conf).</div><div><span class="e" id="q_10d81ab4909963d6_5"><br>
<br>
Philbur<br>
<br>
<br>
<br>
<br>
Nicolas Geraud a écrit&nbsp;:
<blockquote cite="http://mid355856040609051257u4993a32ajd92eae1cd98515fe@mail.gmail.com" type="cite">Pardon pour le retard de ma reponse, bcp de boulot.<br>
  <br>
Francois&gt; Hello, étant en DHCP, je n'ai aucune ip a préciser, c a ma
machine de lancer une requete en broadcast pour recuperer son ip<br>
  <br>
Philbur&gt; ces infos concernent le wifi et je suis en filaire. J'ai
regarde tout de mm mais je ne vois rien ressemblant a mon soucis.
  <br>
  <br>
Sinon je viens de constater, en lancant l'outil graphique
network-admin, que le périphérique par défaut de la passerelle est vide
lorsque ma connexion ne fonctionne pas.<br>
J'ai tenté de selectionner eth0 ds la combo mais ca n'a rien changé.
  <br>
Un petit coup de ifdown/ifup, je relance network-admin, et la je vois
bien eth0 selectionné ds la combo.<br>
  <br>
Savez comment fixer ca?<br>
  <br>
merci<br>
  <br>
  <br>
  <div><span class="gmail_quote">Le 31/08/06, <b class="gmail_sendername">Philbur</b> &lt;<a href="mailto:philbur@worldcom.ch" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">philbur@worldcom.ch</a>
&gt;
a écrit :</span>
  <blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">RE
HELP ! &lt;<a href="https://help.ubuntu.com/community/WIfiDocs/" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">https://help.ubuntu.com/community/WIfiDocs/</a>&gt;<br>
    <br>
Philbur<br>
    <br>
Nicolas Geraud a écrit :
    <br>
&gt; Bonjour à tous.<br>
&gt;<br>
&gt; Depuis peu j'ai reconfiguré ma freebox pour qu'elle fasse office
de
    <br>
&gt; serveur DHCP tout en donnant une association IP fixe / @ mac aux<br>
&gt; machines de mon sous-réseau.<br>
&gt;<br>
&gt; Mais depuis ce changement, lors de la majorité de mes boots, je
n'ai<br>
&gt; pas de réseau (mais eth0 est bien monté).
    <br>
&gt;<br>
&gt; je dois donc faire un petit coup de :<br>
&gt; $&gt; sudo ifdown eth0<br>
&gt; $&gt; sudo ifup eth0<br>
&gt;<br>
&gt;<br>
&gt; quelqu'un aurait il une piste?<br>
&gt;<br>
&gt; Pour info :<br>
&gt;<br>
&gt; ~% cat /etc/network/interfaces
    <br>
&gt; auto lo<br>
&gt; iface lo inet loopback<br>
&gt;<br>
&gt; auto eth0<br>
&gt; iface eth0 inet dhcp<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; merci<br>
    <br>
  </blockquote>
  </div>
  <br>
</blockquote>
<br>
</span></div><div></div>


</div></blockquote></div><br>