problème mise à jour

Avell Diroll avelldiroll at gmail.com
Mer 27 Jan 14:05:36 UTC 2010


Marianne CHIGNIER wrote:
> bonjour,
> je ne peux plus faire les mises à jour, le message suivant s'affiche:
> "Impossible d'initialiser les données sur les paquets
> Un problème insoluble est survenu pendant l'initialisation des informations du paquet.
> Veuillez signaler ce bogue du paquet « update-manager » en y joignant le message d'erreur suivant :
> 'E:Vous avez dépassé le nombre de descriptions que cette version d'APT est capable de traiter., E:Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_hardy_universe_binary-i386_Packages, E:Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.'"
> Que puis (dois)-je faire?

Tout d'abord indiquer précisément la version d'ubuntu que tu utilises. 
Le message d'erreur suggère que c'est "Ubuntu 8.04 LTS Hardy Heron", 
mais cela pourrait faire partie de l'erreur.

Pour déterminer la version il suffit d'entrer la commande suivante dans 
un terminal:

cat /etc/lsb-release

Ensuite il faut vérifier si le disque n'est pas plein:

df -h

Puis il faut voir la configuration de apt et vérifier que ce ne soit pas 
inutilement encombré de dépôts externes:

cat /etc/apt/sources.list

Enfin il est toujours bon de vérifier le fichier /var/lib/dpkg/status 
soit corrompu, mais avant de s'y intéresser il est nécessaire de 
vérifier les étapes précédentes.

Finalement il est toujours bon de vérifier l'intégrité de son disque dur 
(attention l'enchaînement de ces commandes provoque un redémarrage suivi 
d'un test du disque pendant le boot):

sudo touch /forcefsck
sudo reboot

Bonne continuation

Ju
-- 
Shepards are for sheep.




Plus d'informations sur la liste de diffusion ubuntu-fr