passage à la 9-10 son

Séb seb.bubuntu at gmail.com
Ven 6 Nov 10:00:26 GMT 2009


yves-marie wrote:
> Bon je viens de vérifier ce dépôt est bien activé.quand je veux Réinstaller
> le paquet adobe-flashplugin il ne trouve rien je dois être bouché. j'en suis
> désolé.

Si tu as bien fait tout ce que j'ai conseillé et que ce paquet n'est pas 
disponible, c'est que ton architecture doit vraisemblablement être 64 bits et 
non pas 32 bits. En effet, le paquet "adobe-flashplugin" n'est effectivement pas 
disponible pour l'architecture 64 bits.
L'intérêt du 64 bits étant encore très limité (surtout pour une utilisation 
"classique"), je n'avais pas pensé à cette possibilité... Pardon d'avoir était 
un peu sec. Cela dit, c'est pour éviter ce genre d'incompréhension qu'il est 
important de TOUJOURS préciser les détails liés à son problème (pour un problème 
logiciel: version du logiciel, paquet correspondant, version d'Ubuntu, 
architecture, etc...)

Le paquet "adobe-flashplugin" est maintenu par Canonical, c'est pour ça que je 
conseille plutôt d'installer ce paquet plutôt que les autres alternatives.
Maintenant, dans le cas d'une architecture 64 bits, il n'y a (pour l'instant?) 
pas d'autre choix, pour installer le plugin flash d'adobe, que de passer par 
l'installation du paquet suivant: "flashplugin-installer" (ou encore le paquet 
transitoire "flashplugin-nonfree" qui ne fait que "renvoyer" vers le paquet 
"flashplugin-installer").
Comme le conseille Steve, (ré)installes ce paquet et flash devrait marcher.

Précision importante pour la compréhension: ce paquet ne fait que télécharger le 
plugin 32 bits depuis le site d'adobe. Aussi pour fonctionner correctement sur 
une architecture 64 bits, ce plugin nécessite (entres autres) les librairies 32 
bits (paquets "ia32-libs") et un "wrapper" (paquet "nspluginwrapper"). 
Evidemment, ces paquets sont installés automatiquement grâce à la "magie" des 
dépendances.
Cela fait partie des choses qu'il est important de connaître quand on est sous 
64 bits.

Séb




Plus d'informations sur la liste de diffusion ubuntu-fr