Laptop TX1418CA mise à jour!

Sébastien seb.bubuntu at gmail.com
Ven 14 Mar 15:59:22 UTC 2008


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Free Mind wrote:
> 7) LE GROS PROBLÈME, le son!!!!  Ça... hum... ça m'emmerde!
> J'ai mon haut-parleur dans la barre de tâche, malgré que le curseur soit
> au max, j'entends RIEN du tout.  Je n'ai pas d'erreur nul part, comme si
> le son fonctionnait finalement mais que le haut-parleur serait
> débranché, le système croyant qu'il fonctionne... Je soupçonne un
> problème de ALSA.  D'après ce que j'ai vu sur google, il faudrait
> recompiler un driver alsa.  J'ai tenté la procédure mais à l'étape de
> compilation je reçois une erreur majeure alors j'ai laissé tombé.  Je
> crois qu'avec hardy le son fonctionnait.  Je pense donc qu'une mise à
> jour un moment donné va me redonner le son?
> 
> C'est un chip audio: Realtek *ALC861VD*
Parfait, la bonne info et du premier coup (ou presque! ;) )
Tu as même de la chance: c'est mon Chipset audio aussi!
Ce qui est "rigolo", c'est qu'effectivement la carte est reconnue, marche... mais ne fait pas de son
(oh la vilaine!) !
Tout ca à cause d'une mauvaise(?) configuration par défaut de alsa-base ou plus particulièrement du
module snd-hda-intel gérant les chipset HD Audio.
La solution?
Pas besoin de compilation d'Alsa: le Chipset est supporté depuis la version 1.0.14 de ALSA... qui se
trouve être celle installée avec Gutsy (ouf!)
Confirmation: http://www.alsa-project.org/main/index.php/Changes_v1.0.13_v1.0.14

Mais grand dieu! Que faire alors?
La solution se trouve... Sur ton ordinateur!
le fichier texte compressé "/usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz" est installé
avec le paquet alsa-base et contient toutes les infos de configuration de ALSA.
En y cherchant ALC861VD tu tombes sur les options de configurations de ALSA correspondant a ce chipset.
Il ne te reste plus qu'à jouer avec les options du module "snd-hda-intel" en éditant le fichier:
/etc/modprobe.d/alsa-base
Après quelques essais infructueux tu trouveras que l'option convenable est: options snd-hda-intel
model=lenovo

Je te l'accorde, pour trouver la solution à ce problème, il fallait se lever tôt... Ou être feignant
(comme moi!) et aller sur google, taper "Realtek ALC861VD ubuntu gutsy" et tomber en deux clics sur:
http://ubuntuforums.org/showthread.php?t=603809

Pour prendre les changements en compte, le plus simple reste de redémarrer l'ordinateur... Je
précise, juste au coup où... ;)


> 8) Ai-je espoir de faire fonctionner mon modem?  Bref... ce genre de
> modem c'est plutôt rare d'y arriver je pense.  C'est un moindre mal
> comparer au son mais j'aimerais bien si possible avoir mon modem. 
> Quoique la priorité de ce problème est pour moi très très loin.  J'ai vu
> quelque chose concernant le type de mon modem avec slmodemd que
> j'essaierai un jour.  J'y reviendrai avec les détails si vraiment
> j'embarque la dedans...
Pas de modèle, pas de modem! ;)
Plus sérieusement, je n'utilise plus de modems depuis une éternité donc je ne serais d'aucune utilité!

Séb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFH2qDalabueleSRzIRAgpTAKC22/qLlcSu0Ly6wAfh6BcVHwi0tgCeLpO6
7oxEL606OTfoYzo8VVHxunE=
=1UoF
-----END PGP SIGNATURE-----




Plus d'informations sur la liste de diffusion ubuntu-fr