Re: lemanchot at tele2.fr: Re: Dell Insipron 1525 série N / pilotes proriétaires

yves sthorez lemanchot at tele2.fr
Dim 15 Juin 13:56:34 UTC 2008


Christophe Gallaire a écrit :
> Merci Yves pour ta réponse (perso que j'envoie sur la liste).
>
> ----- Forwarded message from yves sthorez <lemanchot at tele2.fr> -----
>
> Bonjour Christophe
>   
>>> Bonjour à tous,
>>>
>>> J'ai reçu il y a quelques mon Dell Inspiron 1525N tout configuré sous 
>>> Ubuntu Feisty. Tout était nickel. Beau travail Dell. Seulement, je 
>>> tourne habituellement sous Debian Lenny et Ubuntu Studio et je me suis 
>>> directement lancé dans une installation de la version 8.04 de Studio. 
>>>
>>> Juste avant, j'ai ouvert le gestionnaire de pilotes propriétaires, j'ai vu deux pilotes installés mais n'ai rien noté. Quelqu'un peut-il me le dire ?
>>>       
>     
>   
>> J'avais la même chose  (DELL INSPIRON *6400N* acheté en octobre) avant de 
>> passer à Gutsy (2 pilotes étaient installés) mais la résolution ne  
>> dépassait jamais 1024 x 786 (Intel Média Accelerator 950). Depuis la Hard 
>> *8.04 LTS*, j'ai l'écran reconnu comme LAPTOP 15" et j'ai enfin 1280 x 800 
>> et pas de pilote proprio (système/préférences/résolution de l'écran).
>>     
>
> Donc... l'un des deux pilotes était celui de la carte graphique, n'est-ce pas ? De ce côté-là, je pense avoir résolu le problème en modifiant /etc/X11/xorg.conf comme suit :
>
> Section "Device" 
> # VendorName "Intel Corporation" 
> # BoardName "Mobile Integrated Graphics Controller" 
>         Identifier "Card0" 
>         Driver "intel" 
>         BusID "PCI:0:2:0" 
>         Option "AccelMethod" "XAA" 
>         Option "XAANoOffscreenPixmaps" "true" 
>         Option "FramebufferCompression" "false" 
>         Option "DRI" "true 
> EndSection
>
> Après plusieurs redémarrage, la bonne nouvelle c'est que la bouillie de pixels a disparu. On verra à la longue si c'est efficace.
>
>   
En ce moment, je n'ai que :
Section "Device"
        Identifier      "Configured Video Device"
EndSection
tout bonnement ...

et ceci dans /etc/x11/xorg.conf.failsafe :
Section "Device"
    Identifier    "Configured Video Device"
    Driver        "vesa"
EndSection
>
>> Même PB avec wifi que je n'ai pas cherché à résoudre pour le moment (plus 
>> de [Fn] [F2] ni d'allumage de diode wifi).
>>     
>
> Donc... le deuxième pilote était celui de la carte WIFI alors ? 
>
> Effectivement, la diode wifi ne s'allume plus... mais bon, dans la mesure où la connexion se fait correctement en deux trois commandes, ça me va... 
>
> Comme le module de la carte est bien chargé, on identifie le nom du périphérique:
>
> iwconfig
>
> wlan0     IEEE 802.11g  ESSID:"MonESSID"  Nickname:""
>            Mode:Managed  Frequency:2.442 GHz  Access Point: 00:16:41:D1:7E:94   
>            Bit Rate=54 Mb/s   Tx-Power=27 dBm   
>            Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
>            Power Management:off
>            Link Quality=75/100  Signal level=-59 dBm  Noise level=-89 dBm
>            Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>            Tx excessive retries:0  Invalid misc:0   Missed beacon:0
>
> Ensuite, on coupe tout et on reconnecte :
>
> sudo ifdown wlan0
>
> sudo ifup wlan0
>
> On liste les réseaux dispos pour identifier le sien :
>
> sudo iwlist wlan0 scan
>
> wlan0     Scan completed :
>            Cell 01 - Address: 00:16:41:D1:7E:94
>                      ESSID:"MonESSID"
>                      Mode:Master
>                      Channel:7
>                      Frequency:2.442 GHz (Channel 7)
>                      Quality=75/100  Signal level=-63 dBm  Noise level=-93 dBm
>                      Encryption key:on
>                      Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
>                                9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
>                                48 Mb/s; 54 Mb/s
>                      Extra:tsf=0000000ace6b0233
>
> Etc.
>
> On configure avec son ESSID :
>
> sudo iwconfig wlan0 essid MonESSID
>
> sudo iwconfig wlan0 key MaCleWEP
>
> Et puis on fixe l'IP :
>
> sudo dhclient wlan0
>
> Voili voilou...
>
> En cas de souci (déconnexion, etc.), normalement il suffit de couper et relancer la connexion :
>
> sudo ifdown wlan0
>
> sudo ifup wlan0
>
>
>   
Je garde ça pour un peu plus tard [ j'ai toujours ma connexion filaire 
;-) ], je nage depuis quelques temps avec des tentatives d'install de 
SPIP, egroupware et autre promethee, le tout sans résultat.

@+
Yves




Plus d'informations sur la liste de diffusion ubuntu-fr