Suite problème mises a jour

Daniel MOUTON danielmouton at wanadoo.fr
Jeu 29 Mar 17:41:33 UTC 2007


Bonjour

  Voici les dernieres infos concernant  le problème de bloquage des mises a jour et installation
    le reponsable     oss-linux-v4.0-1001.i386   et moi aussi bien entendu pour avoir essayer de l'installer

root at unix:/usr# sudo aptitude  show oss-linux
Paquet : oss-linux
État: partiellement configuré
Automatiquement installé: non
Version : v4.0-1001
Priorité : supplémentaire
Section : alien
Responsable : root <root at ubuntu-nvidiahda>
Taille décompressée : 7373k
Dépend: libatk1.0-0 (>= 1.9.0), libc6 (>= 2.3.4-1), libcairo2 (>= 1.0.2-2),
         libfontconfig1 (>= 2.3.0), libglib2.0-0 (>= 2.10.0), libgtk2.0-0 (>=
         2.8.0), libpango1.0-0 (>= 1.12.3), libx11-6, libxcursor1 (> 1.1.2),
         libxext6, libxfixes3, libxi6, libxinerama1, libxrandr2, libxrender1
Description : Open Sound System sound drivers for Linux
 Open Sound System for Linux (OSS/Linux) is a commercial quality sound driver
 distributed by 4Front Technologies (http://www.opensound.com). OSS provides
 support for practically all sound cards on the market including PnP and many
 PCI ones. Installation and configuration is higly automated and easy to
 perform. To obtain technical support and additional features, you will need to
 order a license key from http://www.opensound.com/order.html 
 
 (Converted from a rpm package by alien version 8.64.)


root at unix:/usr# sudo aptitude  remove  oss-linux
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture de l'information d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Construction de la base de données des étiquettes... Fait
Les paquets suivants ont été conservés automatiquement :
  kdelibs-data kdelibs4c2a 
Les paquets suivants ont été conservés :
  evolution evolution-data-server evolution-data-server-common 
  evolution-plugins firefox firefox-gnome-support libaudio2 libcamel1.2-8 
  libebook1.2-9 libecal1.2-7 libedata-book1.2-2 libedata-cal1.2-6 
  libedataserver1.2-7 libedataserverui1.2-8 libegroupwise1.2-12 
  libexchange-storage1.2-2 liblircclient0 libnautilus-extension1 libnspr4 
  libnss3 nautilus nautilus-data openoffice.org openoffice.org-base 
  openoffice.org-calc openoffice.org-common openoffice.org-core 
  openoffice.org-draw openoffice.org-evolution openoffice.org-gnome 
  openoffice.org-gtk openoffice.org-impress openoffice.org-java-common 
  openoffice.org-l10n-en-us openoffice.org-math 
  openoffice.org-style-default openoffice.org-style-industrial 
  openoffice.org-writer popularity-contest python-uno ttf-opensymbol unrar 
  update-notifier xmms 
Les paquets suivants seront ENLEVÉS :
  oss-linux 
0 paquets mis à jour, 0 nouvellement installés, 1 à enlever et 46 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 7373ko seront libérés.
Écriture de l'information d'état étendu... Fait
dpkg : erreur de traitement de oss-linux (--remove) :
 Le paquet est dans un état incohérent - vous devriez
 le réinstaller avant d'essayer de le supprimer.
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct NULL not valid
Abandon (core dumped)
root at unix:/usr# Des erreurs ont été rencontrées pendant l'exécution :
 oss-linux

root at unix:/usr# 

root at unix:/usr# sudo dpkg --remove --force-depends --force-remove-reinstreq oss-linux
dpkg - avertissement, problème contourné à cause de --force :
 Le paquet est dans un état incohérent - vous devriez
 le réinstaller avant d'essayer de le supprimer.
(Lecture de la base de données... 
dpkg : avertissement important : le fichier contenant la liste des fichiers du paquet « oss-linux » étant manquant, il est considéré qu'aucun fichier du paquet n'est actuellement installé.
154007 fichiers et répertoires déjà installés.)
Suppression de oss-linux ...
sh: Can't open /usr/lib/oss/scripts/restore_drv.sh
dpkg : erreur de traitement de oss-linux (--remove) :
 le sous-processus pre-removal script a retourné une erreur de sortie d'état 2
Building OSS Modules for Linux-unknown 2.6.17-11-generic
cd: 3: can't cd to /usr/lib/oss/build
sh: Can't open install.sh
Starting Open Sound System
/var/lib/dpkg/info/oss-linux.postinst: 7: /usr/sbin/soundon: not found
dpkg : erreur lors du nettoyage :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 127
Des erreurs ont été rencontrées pendant l'exécution :
 oss-linux
root at unix:/usr# 

    je suis allé sur  nombre de forum  français et etrangers et il apparait que le problème soit 
   dans beaucoups de cas  insurmontable   il semblerait que le paquet en question  oss-linux-v4.0-1001.i386.rpm ou .deb
     soit  bugé ou incomplet 

    Si   quelqu'un a une idée   meme dangereuse 

    A votre avis     j'insiste   ou  je reinstalle   ?

                               Bonne journée a tous
 





Plus d'informations sur la liste de diffusion ubuntu-fr