pipe des commandes dans le terminal

Helfer Thomas helferthomas at free.fr
Sam 30 Sep 16:59:45 UTC 2006


Effectivement ça marche, c'est assez pénible comme bug...

Thomas

Le samedi 30 septembre 2006 à 18:42 +0200, Jérémy a écrit :
> Helfer Thomas a écrit :
> > Si si grep est bien installé...
> > $ grep
> > Usage: grep [OPTION]... PATRON [FICHIER]...
> > Pour en savoir davantage, faites: « grep --help ».
> >   
> Non c'est pas un problème d'installation, ca me le fait aussi parfois, 
> j'ai jamais compris pourquoi !! Quand ca t'arrives, fait :
> ls |grep "*.cxx" (sans espace entre ton pipe et grep)
> ca va fonctionner,
> et après tu pourras faire de nouveau
> ls | grep "*.cxx", ca marchera c'est un bug j'imagine. ca n'arrive pas 
> souvent ! mais ca arrive parfois
> 
> >
> > Le samedi 30 septembre 2006 à 18:30 +0200, Charles Duval a écrit :
> >   
> >> Helfer Thomas a écrit :
> >>     
> >>> Bonjour,
> >>>
> >>> j'utilise le terminal gnome. Je n'arrive pas à comprendre pourquoi la
> >>> command suivante ne marche pas :
> >>> $ ls | grep "*.cxx"
> >>> bash:  grep : commande introuvable
> >>>   
> >>>       
> >> Bonjour,
> >>
> >> grep ne semble pas installé. Pour le vérifier:
> >> $sudo apt-get update           <= pour mettre a jour la base de données 
> >> des packages
> >> $sudo apt-get install grep   <= cette commande installera grep et toutes 
> >> les dépendances nécessaire.
> >>
> >> Bonne chance,
> >>     
> >>> la commande locale me dit que je suis en UTF8, mais passer en FR_fr at euro
> >>> ne change pas grand chose..
> >>>
> >>> Avez-vous une idée ?
> >>>
> >>> Cordialement, 
> >>>
> >>> Helfer Thomas
> >>>
> >>>
> >>>   
> >>>       
> >>     
> >
> >
> >   
> 
> 





Plus d'informations sur la liste de diffusion ubuntu-fr