Problème configuration carte Wifi BCM4318

Jérémy ozstrycker at wanadoo.fr
Sam 30 Sep 08:47:00 BST 2006


Helfer Thomas a écrit :
> Bonjour,
>   
Bonjour :o)
> j'ai récemment installé une ubuntu drapper drake sur un portable asus
> amd64. Celui-ci possède une carte Wifi BCM4318. 
>
> Après de nombreux essais, je me trouve dans une impasse. Suivant les
> différents wiki français et anglais sur ubuntu, plus quelques recherches
> google, je suis à bout de ressources. Je vais essayer de vous décrire le
> problème de la manière la plus claire possible
>
> D'abord un petit lspci :
> #lspci	
> 0000:03:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce
> One 54g] 802.11g Wireless LAN Controller (rev 02)
>
> Apparemment, le driver noyau bcmxxx ne supporte ma carte. Je l'ai donc
> blacklisté : 
> # cat /etc/modprobe.d/blacklist
> blacklist bcm43xx
>
> j'ai ensuite installé ndiswrapper en faisant attention de prendre les
> drivers pour amd64.
> # ndiswrapper -l
> Installed ndis drivers:
> bcmwl5          driver present, hardware present
>   
Normalement pas de problèmes de ce côté là ! Driver présent hardware 
aussi donc ndiswrapper est bien installé et fonctionne bien en théorie.
> iwconfig me donne :
> lo        no wireless extensions.
>
> eth1      no wireless extensions.
>
> sit0      no wireless extensions.
>
> eth0      IEEE 802.11g  ESSID:off/any
>           Mode:Managed  Frequency:2.462 GHz  Access Point:
> Not-Associated
>           Bit Rate=54 Mb/s   Tx-Power:25 dBm
>           RTS thr:off   Fragment thr:off
>           Power Management:off
>           Link Quality:0  Signal level:0  Noise level:0
>           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
>
> eth0 semble bien être la carte wifi. eth1 est la carte réseau ethernet.
>
> J'ai donc configuré eth0 dans mon /etc/network/interfaces. J'ai repris
> la conf de mon ancien portable, elle doit marcher. Un ifup eth0 marche, 
> mais impossible d'aller sur le réseau.
>   
Est-ce que tu pourrais nous copier-coller ton /etc/network/interfaces ?
> ifconfig me donne alors:
> #ifconfig
> eth0      Lien encap:Ethernet  HWaddr 00:17:31:30:08:7C
>           inet adr:192.168.0.10  Bcast:192.168.0.255
> Masque:255.255.255.0
>           adr inet6: fe80::217:31ff:fe30:87c/64 Scope:Lien
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
>           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 lg file transmission:1000
>           Octets reçus:0 (0.0 b) Octets transmis:0 (0.0 b)
>           Interruption:11 Mémoire:df7fc000-df7fe000
>
> Ce qui semble correct.
>   
A moi aussi :o)
> J'ai par ailleurs remarqué plusieurs points étranges :
> # dmesg > dmesg.txt
> # grep eth0 dmesg.txt
> [   42.243585] eth0: Identified chip type is 'RTL8168B/8111B'.
> [   42.243589] eth0: r10001.02, the Linux device driver for Realtek
> Ethernet Controllers at 0xc800, 00:17:31:e5:1f:aa, IRQ 11
> [   42.244602] eth0: Auto-negotiation Enabled.
> [   44.008260] eth0: 100Mbps Full-duplex operation.
> [  616.823094] eth0: no IPv6 routers present
>
> # grep eth1 dmesg.txt
> [   54.969018] eth1: no IPv6 routers present
>
> # grep ndiswrapper dmesg.txt
> [   44.907094] ndiswrapper version 1.8 loaded (preempt=yes,smp=yes)
> [   44.966717] ndiswrapper (load_pe_images:571): fixing
> KI_USER_SHARED_DATA address in the driver
> [   44.968349] ndiswrapper: driver bcmwl5 (Broadcom,02/11/2005,
> 3.100.64.0) loaded
> [   44.976581] ndiswrapper: using irq 11
> [   46.204570] wlan0: ndiswrapper ethernet device 00:17:31:30:08:7c
> using driver bcmwl5, 14E4:4318.5.conf
>
> De ces messages, je comprends que ndiswraper me crée une interface
> wlan0, que ma carte ethernet est sur eth0. En contradiction avec
> iwconfig...
>
> J'ai alors regardé dans /etc/modprobe.d/ndiswrapper :
> # cat /etc/modprobe.d/ndiswrapper
> alias wlan0 ndiswrapper
>
> J'ai changé wlan0 en eth0 et reboot, mais rien n'y fait.... Je crois que
> j'ai épuisé mes ressources. Quelqu'un y comprend-t'il quelque chose ?
>   
Essaye de remettre wlan0 dans ce fichier, comme c'était d'origine et 
reboot, puis vérifie qu'ndiswrapper est bien chargé au démarrage (avec 
lsmod) et regarde la sortie de iwconfig.
fais un ifconfig eth1down (pour désactiver la carte ethernet des fois 
que ca pose problème) et ensuite configure ton accès wifi comme ca 
(remplace [iface_wifi] par le nom de l'interface wifi qu'iwconfig 
t'auras donné, ca sera soit wlan0 soit eth0 normalement :

(Je suppose que t'as une clé WEP et que t'as un dhcp activé)

iwconfig [iface_wifi] essid [ton_essid]
iwconfig [iface_wifi] key on
iwconfig [iface_wifi] key [ta_clé_wep]
dhclient [iface_wifi]

Ensuite vérifie que les changements sont bien pris en compte en faisant 
iwconfig [iface_wifi], normalement si c'est OK t'as l'adresse MAC de ton 
Access Point qui s'affichera et ton SSID aussi.

En théorie ca devrait fonctionner. Si ca foire hésite pas à nous 
balancer les messages d'erreur etc. comme t'as fais dans ton mail 
précédent ma fois très bien rédigé :o)
> Merci pour votre aide	
>
> Helfer Thomas
>
>
>   





Plus d'informations sur la liste de diffusion ubuntu-fr