Dapper et Wifi

Benoit HETRU hetrube at looponblue.net
Dim 28 Mai 10:29:05 UTC 2006


christian a écrit :
> Thierry LEGAY a écrit :
>> Aucun message d'erreur.(au moins j'aurais su d'où cela venait!).. Je
>> vais dans Système -> Administration -> Réseau, les paramètres sont
>> corrects car ce sont les mêmes qu'avant dans Breezy (j'ai aussi
>> essayé en IP fixe, c'est pareil).. Mieux, le programme de test pour
>> KDE (je ne sais plus son nom) trouve mon réseau (et celui du voisin),
>> dit que la connexion est excellente, mais Firefox ne se connecte
>> plus, ni Thunderbird... Il doit y avoir un fichier de config qui a
>> été modifié, mais lequel ? Et, de toutes façons, ce n'est pas
>> normal... J'ai essayé aussi de remettre le pilote de Windows avec
>> ndiswrapper, ndiswrapper -l me dit "hardware present etc..." mais ça
>> ne change rien !!! Quand je regarde la liste des périphériques, je
>> trouve bien ma carte, avec son nom, son processeur (un TI ACX111),
>> donc elle est bien reconnue par le système....
> ça n'explique pas le phénomène, mais un truc dans ce genre m'est
> arrivé, j'ai juste désactivé la carte wi-fi dans le menu
> syst.->admin.->Reseau... puis réactivé et ça à marché !
> Si aucune des solutions proposées par albert et marian ne t'aide,
> essaie ça on ne sais jamais et si quelqu'un peut expliquer ce qui ce
> passe, je suis preneur, car j'aime bien comprendre ce qui ce passe
> dans la boite.
> cordialement,
> Chris
Salut,

J'ai eu un cas tout à fait identique sur un de mes PC. Le problème
venait des drivers experimentaux pour les chipset Broadcom qui sont
inclus dans Dapper. Ces drivers detectent la carte, la signalent
correctement, mais sont incapables de communiquer correctement sans
avoir à faire un tas de manips (et même là, c'est pas garanti que ça
marche). Un autre problème est également que, tant que ces drivers sont
activés, ndiswrapper est inutilisable (même s'il ne remonte aucun
message d'erreur).
La solution que j'avais trouvé était de blacklister le module concernant
les drivers experimentaux au démarrage, ça permettait de faire marcher
correctement ndiswrapper par la suite.
Tu trouveras plus de précisions sur
https://wiki.ubuntu.com/WifiDocs/Driver/Broadcom43xx#head-ac54203b378488616214f988abe118882caf3bae
Si tu n'as pas de chipset broadcom, je sais pas trop. J'ai cru
comprendre qu'on pouvait avoir le même problème avec acx, mais sans
jamais avoir pu le tester.

En esperant que ça aide.

Benoit




Plus d'informations sur la liste de diffusion ubuntu-fr