le son-breezy-amd64

Jeremy Vies jeremy.vies at gmail.com
Mar 24 Jan 09:50:50 UTC 2006


Le build-essential ne contient que les dépendances pour fabriquer les applis
"normales"...

Sauf chez les geeks, on ne recompile pas son kernel tous les matins...

Essaye d'installer "gcc-3.4", et de voir si ça marche comme ça. Si ça
fonctionne toujours pas, il faut peut être placer la variable
d'environnement CC à gcc-3.4 (i.e taper "export CC=gcc-3.4" dans le terminal
avant de lancer la compilation).

JV

Le 24/01/06, Isabella <bapoumba at gmail.com> a écrit :
>
>
>
> 2006/1/24, Jeremy Vies <jeremy.vies at gmail.com>:
> >
> > Salut,
> >
> > Je suis pas un spécialiste alsa et autre bizarreries sonores, mais je
> > peux t'aider sur tes problèmes de kernel et de compilo.
> >
> > Je crois que le kernel par défaut est compilé avec gcc 3.4. Il faut
> > compiler les modules avec le même compilo, donc il te faut l'installer (
> > gcc-3.4). Il te faudra aussi les headers de ton kernel, probablement
> > linux-headers-2.6.12, ou un truc du genre...
>
>
> Salut Jeremy
>
> j'ai les headers :
> linux-headers-2.6.12-10-amd64-k8, Linux kernel headers 2.6.12 on AMD K8,
> version 2.6.12-10.26 (la plus récente me semble-t-il).
>
> Et ça fait bien parti des problèmes de compilo souvent référencés dans les
> > forums / ML...
> > Ubuntu a fait le choix de passer à gcc 4.0.2 avant que le noyau ne soit
> > compatible avec gcc 4. Ils ont donc compilé (presque) toutes les applis avec
> > gcc 4, mais le noyau avec gcc 3.4.
>
>
> J'ai gcc, gcc-3.3 (+base), gcc-3.4-base (???) et gcc-4.0 (+base) et les
> libs lib32gcc1 et libgcc1.
> Donc j'installe gcc-3.4 et je continue ?
> Pourtant j'ai le build-essential...
>
> merci,
> Isabella
>
>
>
-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...
URL: <https://lists.ubuntu.com/archives/ubuntu-fr/attachments/20060124/c408b393/attachment.html>


Plus d'informations sur la liste de diffusion ubuntu-fr