pb configuration modem USB alcatel speedtouch suite

François Schoubben fsc at info.fundp.ac.be
Mer 20 Oct 07:39:23 UTC 2004


prokoschnov wrote:
>     Date: Tue, 19 Oct 2004 01:06:23 +0200
>     From: prokoschnov <prokoschnov at wanadoo.fr>
>     Subject: configurer modem speedtouch usb
>     To: ubuntu-fr at lists.ubuntu.com
>     Message-ID: <54B1C108-215A-11D9-98F0-00039381E442 at wanadoo.fr>
>     Content-Type: text/plain; charset="iso-8859-1"
> 
>     bonjour
> 
>     tout d'abord, je tiens à signaler que je suis pour l'instant très
>     content de la distrib ubuntu. Enfin, une distrib ppc basée sur une
>     debian qui marche sur un G4 équipée d'une radeon... :-)
>     Elle marche très bien sur les G4 y compris sur les eMac... (je viens
>     bientôt tester sur des G5 mono et bi proc)
>     Cette distrib m'a tellement plu que j'ai décidé de l'installer aussi à
>     la maison. Mais n'étant plus sur le réseau ethernet du boulot, je dois
>     utiliser mon modem alcatel speedtouch usb. Et là, galère...
>     j'arrive pas à configurer ma connexion. J'ai pourtant lu quelques
>     tutoriaux, il y a un truc qui m'échappe...
> 
>     config : G4 - 733 MHz - 896 Mo Ram
>     modem : alcatel speedtouch USB (pour ADSL)
>     kernel : 2.6.8-1.2
> 
>     ce qui est très curieux, c'est qu'il me semble que mon modem soit
>     reconnu.
>     je le trouve là :
>     -------------- section suivante --------------
>     Une pièce jointe non texte a été nettoyée...
>     Nom: captureconfig.png
>     Type: image/png
>     Taille: 81421 octets
>     Desc: non disponible
>     Url:
>     http://lists.ubuntu.com/archives/ubuntu-fr/attachments/20041019/db40625c/captureconfig.png
> 
>     -------------- section suivante --------------
> 
> 
>     j'ai lu attentivement un tutorial écrit par serge tchesmeli, mis à jour
>     par jice. Il est en rapport avec les drivers de Benoit Papillault...
>     Mais ce tutorial semble dater un peu (vu les références de kernel).
>     :-(
> 
>     cependant, j'ai déjà des pistes concernant des pb de config
> 
>     par exemple, que je tape :
>     # modprobe n_hdls
> 
>     la réponse est : "FATAL n_hdlc not found"
>     donc première question, est-ce que la dernière distrib de ubuntu inclus
>     le support hdlc ? a priori non... et si je me goure pas, alors que
>     faire ?
> 
>     de même dans le fichier /etc/modules.conf
>     la ligne suivante semble manquante
> 
>     alias tty-ldisc-13 n_hdlc
> 
>     est-ce grave ?
> 
>     plus fort encore : quand je tape
>     # pppd
> 
>     j'ai pour réponse :
>     pppd is unable to open /dev/ppp device
>     il me demande ensuite de taper
>     # mknod /dev/ppc c 108 0
>     mais franchement, ça n'a pas l'air de changer grand-chose...
> 
>     bon bref, en clair je rame sévère
>     les seules choses qui n'ont pas foirés sont :
>     l'install via un package debian ( speedtouch_131-2_powerpc.deb , mais
>     est-ce le bon ?! )
>     et les éditions des fichiers suivants :
>     /etc/ppp/peers
>     /etc/ppp/chap-secrets
>     /etc/ppp/pap-secrets
> 
>     voilà
> 
>     merci d'avance pour votre aide, parce que le temps que j'explique à
>     wanadoo que j'ai installé ubuntu sur un mac, hem, bon, bref....
> 
>     merci de votre aide.
> 
>     Prokoschnov.
> 
> 
> Chose curieuse après édition des fichiers dans /etc/ppp/
> maintenant, au démarrage, il me lance les messages suivants"
> 
> /starting ADSL connection
> OHCI support/
> 
> et puis
> 
> /FIRMWARE_FILE/ /undefined/
> 
> bref apparemment, il doit pas trouver le firmware (pourtant, j'ai pris 
> le bon, je l'ai bien mis dans le bon dossier, en le renommant , en clair
> /usr/local/share/speedtouch/*mgmt.o*
> 
> Donc, à votre avis où est mon erreur ? ça à un rapport avec le support 
> OHCI, le firmware de mon modem, ou le n_hdlc ?
> je sèche
> 
> merci de votre réponse.
> 
> Prokoschnov
> 

Bonjour,

Et bon courage :-)

En effet, faire tourner ce modem sous Debian en général, c'est chaud. 
J'en ai un moi-même, et je ne suis encore jamais arrivé à le faire 
tourner en même temps que hotplug (qui gère les "pluggage" à chaud des 
périphériques). J'y suis arrivé sans, sur une Debian Testing (Sarge), en 
faisant des scripts pas propre à la main... Je n'y suis pas encore 
arrivé sous Ubuntu (mais j'ai pas encore essayé beaucoup).

Des pistes de réponse sont
- le package speedtouch : 
http://sourceforge.net/project/showfiles.php?group_id=3581&package_id=16303
- http://www.linuxselfhelp.com/HOWTO/mini/BTI-PPP/x198.html
- et pour ubuntu, on en parle en anglais là :
   http://lists.ubuntu.com/archives/ubuntu-users/2004-October/005278.html
   http://lists.ubuntu.com/archives/ubuntu-users/2004-October/005454.html
   http://lists.ubuntu.com/archives/ubuntu-users/2004-October/006120.html


Si tu y arrives, fait moi signe :-) Je vais essayer d'y regarder ce soir 
aussi.

-- 
Francois




Plus d'informations sur la liste de diffusion ubuntu-fr