Upgrader le driver nvidia en dernière version

Eric Deleforterie eric at deleforterie.com
Dim 12 Déc 20:58:16 GMT 2004


Selon Renaud Mouren <renaud.mouren at free.fr>:

> Le dimanche 12 décembre 2004 à 14:44 +0100, Eric Deleforterie a écrit :
> > Selon Renaud Mouren <renaud.mouren at free.fr>:
> >
> > > bonjour,
> > >
> > > "en principe" une fois installé le"nvidia-glx il faut taper dans une
> > > console :
> > > sudo nvidia-glx-config enable
> > >
> > > ça doit suffire normalement.
> > >
> > >
> > Salut
> >
> > Oui bien sur lorsque le driver nvidia prend en charge la toute dernière
> carte
> > sortie de l'usine, ce qui n'est pas le cas pour la Geforce 6600 GT avec le
> > driver fournit pas ubuntu.
> >
> > Par conséquent il faut recompiler le driver avec la bonne version toute
> chaude
> > sortie de chez nvidia, et pour ce faire il te faut 2 trucs : le nvidia-glx
> et
> > le nvidia-kernel et qu'ils soient tous les deux dans la même version, pour
> mon
> > plus grand malheur j'ai le bon glx dans la version 6629, mais pas le kernel
> > dans la 6629 !!!
> >
> > Donc pour le moment, pas de X sous ma ubuntu depuis que j'ai mis ma
> nouvelle
> > carte !!!
> >
> > Bye
> >
> Et avec l'installeur d'Nvidia ? normalement si tu a installé les
> kernel-header ça doit passer , non ?
>
> renaud
>
Bah non

Vu que ça commençait à me prendre la tête je suis passé en hoary où il y a le
6629.

Mais là encore, gros soucis, car la version glx est bien la 6629, mais la
kernel-common est la 6111, donc ça match pas :'(

J'ai tenté une install avec le truc de nvidia, mais il compile pas, alors que
j'ai tout mis : les headers et les sources.

Il me sort sur la compile du nvidia.ko un truc comme quoi il cherche un PENTIUM4
alors que ce serait un 386 de config dans mes sources :

nvidia: version magic '2.6.8 SMP preempt PENTIUM4 gcc-3.3' should be '2.6.8 SMP
preempt 386 gcc-3.3'


C'est dingue, comment faire pour qu'il me remette le kernel en 6629.
si je lui demande de me mettre un ubuntu-restricted-modules, il me met aussi les
 paquets lilo, linux-image-2.6.9 et autres choses, visiblement il me passe sur
le noyau 2.6.9, c'est un peu lourd pour mettre un module nvidia à jour.






Plus d'informations sur la liste de diffusion ubuntu-fr