Upgrader le driver nvidia en dernière version

Eric Deleforterie eric at deleforterie.com
Sam 11 Déc 20:18:30 GMT 2004


Selon David Correia <baal-uix at wanadoo.fr>:

> Le samedi 11 décembre 2004 à 11:13 +0100, Eric Deleforterie a écrit :
> > Selon Christophe Bliard <christophe.bliard at netcourrier.com>:
> >
> > > Eric Deleforterie a écrit :
> > > > Salut
> > > >
> > > > Comment faire pour passer sur le dernier driver Nvidia sur une warty ?
> > > > Je viens d'acquérir une 6600 GT AGP et le dernier driver ( 6629 ) est
> le
> > > seul Ã
> > > > fonctionner avec cette carte.
> > > >
> > > > Comment faire pour l'installer sous ma warty ?
> > >
> > > Ce que tu peux essayer de faire, avec synaptic, c'est de
> > > 1- Changer warty en hoary dans les dépôts (menu Catégories ->
> Dépôts)
> > > 2- Recharger les paquets pour avoir ceux de la hoary
> > > 3- Rechercher le paquet nvidia-glx, actuellement version 1.0.6111ubuntu7
> > > 4- Choisir de le mettre à jour (et seulement ce paquet là et ses
> > > dpéendances éventuelles !)
> > > 5- Remettre warty dans les dépôts
> > > 6- Recharger les paquets pour avoir ceux de la warty
> > >
> > > voilà :) ça devrait fonctionner.
> > >
> > > Christophe
> > >
> >
> >
> > Salut
> >
> > Malheureusment le problème est la version proposée, il me faut celle-ci :
> >
> > Version : 1.0-6629
> > Système d’exploitation : Linux IA32
> > Date de rélisation : 5.11.04
> > Principales caractéristiques
> > * Prise en charge du GeForce 6600 et du GeForce 6600 GT
> >
> > Ma carte est une 6600 GT AGP toute fraîche sortie du moule et le driver
> nvidia
> > proposé par ubuntu n'est pas assez récent:'(
> >
> > J'ai essayé de compiler via le xserver-config ou un truc comme ça, mais
> il
> > voulait les kernel-source, chose que je n'ai pu installer car il me propose
> des
> > kernel autre que le 2.6.8.1 qui est installé :'(
> >
> > sniff
> > comment faire ?
> >
> C'est simple pour avoir tes source recherche à linux- au lieu de kernel-
> et tu les aura, voilà :-p

Effectivement là c'est mieux, enfin j'ai les bons sources, mais  ça résoud pas
le problème :'(.

Après quelques recherches, j'ai trouvé ça à rajouter dans le source.list :

deb http://people.ubuntu.com/~daniels/ l-r-m/$(ARCH)

on y trouve ça :

nvidia-glx-dev_1.0.6629-1ubuntu7_i386.deb
nvidia-glx_1.0.6629-1ubuntu7_i386.deb
nvidia-kernel-source_1.0.6629-1ubuntu7_i386.deb

J'ai donc upgradé le glx, mais il n'ya pas de nvidia-kernel, donc je me suis
dis, bah comme au bon vieux temps, compile le, car X est pas super enthousiaste
quand tu n'as pas la version de glx qui match avec celle du nvidia-kernel.

Mais ça marche pas la compile, il me sort ça :

*** Unable to determine the target kernel version. ***

Donc j'essaye avec ça :

make SYSINCLUDE=/usr/src/linux-source-2.6.8.1/include

Mais ça me sort la même chose, sniff j'ai plus X, même avec le module nv, ça
fonctionne plus, la carte est trop récente !!!!

Je comprends pas du temps que j'étais sur la mandrake et que le driver nvidia
linux demandais une compile à chaque nouvelle veriosn, ça fonctionnais bien
!!!!

Là je ne comprends pas pourquoi il me sort ça à la compile, surtout lorsque je
lui donne le SYSINCLUDE !!!

Au secourssssss !!! :)






Plus d'informations sur la liste de diffusion ubuntu-fr