desinstalar java por completo

Ever Medina ever.medinaftal en gmail.com
Vie Nov 22 20:45:53 UTC 2013


Tengo solo instalado openjdk-6-jre, pero desde Synaptic al darle la
orden de desinstalar por completo me pide instalar la versión 7.
Gracias nuevamente.

Ever

El día 22 de noviembre de 2013 12:39, Mauricio J. Adonis C.
<mike.alfa.2007 en gmail.com> escribió:
> El 20/11/13 12:15, Mauricio J. Adonis C. escribió:
>
> El 20/11/13 00:38, Ever Medina escribió:
>
> El 18/11/13, Braiam Miguel Peguero Novo <braiamp en gmail.com> escribió:
>
> Creo que la pregunta importante es, como lo instalaste?
>
>
> El día 18 de noviembre de 2013 15:11, Guido Ignacio
> <guidoignacio en gmail.com> escribió:
>
> El día 18 de noviembre de 2013 16:06, Ever Medina
> <ever.medinaftal en gmail.com> escribió:
>
> hola a todos, necesito desinstalar java por completo, ya que estoy
> teniendo
> problemas con gvSIG (un programa de SIG programado en java) y necesito
> desinstalar y volver a instalar para ver si el problema persiste. El
> centro
> de software no me es suficiente, quiero borrar todo desde consola, ya lo
> intente y no funciono. Me ayudan con los comandos? Si hago esto podría
> generar problemas en otros programas que funcionen con java? donde se
> encuentra instalado java? así borro cualquier carpeta que contenga algún
> archivo de configuración remanente.
> Estas son las características de lo que uso en cuanto a software y
> equipo.
> SO: Ubuntu Versión 12.04 (precise) de 32-bit. Núcleo Linux
> 3.2.0-54-generic-pae. GNOME 3.4.2
> Hardware: RAM 2 GiB. Procesador Intel® Core™2 Duo CPU T5450 @ 1.66GHz ×
> 2
> Espacio disponible en disco: 73,4 GiB
>
> gvSIG version: 1.12.0 final (Build 1417)
> JAVA vendor: Sun Microsystems Inc. version:1.6.0_27
>
> $ dpkg -l |grep java
>
> y vemos que te devuelve...
>
> --
> Guido Ignacio <guidoignacio en gmail.com>
>
> --
> ubuntu-es mailing list
> ubuntu-es en lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>
> --
> Braiam Peguero
>
> lo instale con el Centro de Software de Ubuntu, en algún momento tuve
> J1.6 y 1.7 instalados al mismo tiempo, y no los podía desinstalar, y
> borre lo que encontré con Synaptic. Y después reinstale con el Centro
> de Software. Pero los problemas persisten. Seguramente hice mal.
> Lo que me devuelve la consola es:
>
> ii  ca-certificates-java                              20110912ubuntu6
>                             Common CA certificates (JKS keystore)
> ii  gir1.2-javascriptcoregtk-3.0
> 1.8.3-0ubuntu0.12.04.1                       GObject introspection
> data for the GTK+-based JavaScriptCore library
> ii  gjs                                               1.32.0-1ubuntu1
>                             Mozilla-based javascript bindings for the
> GNOME platform
> ii  java-common                                       0.43ubuntu2
>                             Base of all Java packages
> ii  javascript-common                                 8
>                             Base support for JavaScript library
> packages
> ii  libapache-pom-java                                10-2
>                             Maven metadata for all Apache Software
> projects
> ii  libatk-wrapper-java                               0.30.4-0ubuntu2
>                             An ATK implementation for Java using JNI
> ii  libatk-wrapper-java-jni                           0.30.4-0ubuntu2
>                             An ATK implementation for Java using JNI
> (jni bindings)
> ii  libbackport-util-concurrent-java                  3.1-3
>                             backport of java.util.concurrent to Java
> 1.4
> ii  libbsf-java                                       1:2.4.0-5
>                             Bean Scripting Framework to support
> scripting languages in Java
> ii  libcommons-codec-java                             1.5-1
>                             encoder and decoders such as Base64 and
> hexadecimal codec
> ii  libdom4j-java                                     1.6.1+dfsg.2-5
>                             flexible XML framework for Java
> ii  libgjs0c                                          1.32.0-1ubuntu1
>                             Mozilla-based javascript bindings for the
> GNOME platform
> ii  libjavascriptcoregtk-1.0-0
> 1.8.3-0ubuntu0.12.04.1                       Javascript engine library
> for GTK+
> ii  libjavascriptcoregtk-3.0-0
> 1.8.3-0ubuntu0.12.04.1                       Javascript engine library
> for GTK+
> ii  libjaxen-java                                     1.1.3-1
>                             Java XPath engine
> ii  libjaxme-java                                     0.5.2+dfsg-6
>                             implementation of the JAXB specification
> for Java/XML binding
> ii  libjaxp1.3-java                                   1.3.05-2ubuntu2
>                             Java XML parser and transformer APIs (DOM,
> SAX, JAXP, TrAX)
> ii  libjdom1-java                                     1.1.2+dfsg-2
>                             lightweight and fast library using XML
> ii  liblog4j1.2-java                                  1.2.16-3ubuntu1
>                             Logging library for java
> ii  libmozjs185-1.0
> 1.8.5-1.0.0-0ubuntu8                         Spidermonkey javascript
> engine
> ii  libobasis4.1-extension-javascript-script-provider 4.1.2.3-3
>                             Script provider for JavaScript extension
> for LibreOffice 4.1 .2.3
> ii  libsaxon-java                                     1:6.5.5-8
>                             Saxon XSLT Processor
> ii  libxalan2-java                                    2.7.1-7
>                             XSL Transformations (XSLT) processor in
> Java
> ii  libxerces2-java                                   2.11.0-4
>                             Validating XML parser for Java with DOM
> level 3 support
> ii  libxml-commons-external-java                      1.4.01-2
>                             XML Commons external code - DOM, SAX, and
> JAXP, etc
> ii  libxml-commons-resolver1.1-java                   1.2-7
>                             XML entity and URI resolver library
> ii  libxom-java                                       1.2.1-3
>                             A new XML object model for Java
> ii  libxpp2-java                                      2.1.10-7
>                             XML pull parser library for java V2
> ii  libxpp3-java                                      1.1.4c-2
>                             XML pull parser library for java
> ii  tzdata-java
> 2013g-0ubuntu0.12.04                         time zone and
> daylight-saving time data for use by java runtimes
>
> Hola.
> Si no has instalado ningún repositorio extra a los oficiales, entonces has
> estado instalando la implementación abierta de Java, o sea openJDK porque en
> los repos no hay ningún paquete Java privativo (como el oficial de Oracle).
>
> Por favor, en una terminal ejecuta el siguiente comando y postea la
> salida...
>
> java -version
>
> Yo no uso la versión abierta de Java, no porque no apoye el software libre
> sino porque en algunos casos da ciertos problemas, algunos son pequeños
> detalles otros no tanto.
>
> Eliminar completamente openJDK es bastante sencillo, justamente basta con
> utilizar Synaptic y ubicar el paquete openjdk-6-jre, darle clic derecho
> sobre al mismo y escoger «Marcar para desinstalar completamente». Igual con
> la otra versión, openjdk-7-jre.
>
> Para tener la versión Oracle de Java tienes que agregar un repositorio
> adicional. La instalación de este repositorio se hace mediante los
> comandos..
>
> sudo add-apt-repository ppa:webupd8team/java
> sudo apt-get update
> sudo apt-get install oracle-java7-installer
>
> Instalando la versión 7 de Java de Oracle (también están disponibles las
> versiones 6 y 8)
>
> Saludos,
> Mauricio J. Adonis C.
>
>
> Hola.
> Me alegro que hayas resuelto tu problema. No estaría mal que enviaras un
> mensaje (en el hilo que iniciaste) agregando un «RESUELTO» al asunto del
> mismo.
>
> Las listas de correos sirven como repositorio del conocimiento acumulado y
> que se ha adquirido con el tiempo en toda la comunidad de usuarios, por eso
> es importante seguir ciertos lineamientos que harán que la lista funcione
> según fue ideada. Con este fin es importante leer el siguiente informativo
> al respecto: https://wiki.ubuntu.com/LineamientosListadeCorreos
>
> Las versiones abierta y privativa de Java pueden coexistir en el computador
> sin problemas, pero cuando abras un navegador e intentes ejecutar alguna
> aplicación Java, pues va a seguir utilizando el plugin java de Icedtea, o
> sea la openJDK, aunque esté instalada la versión de Oracle (*).
>
> Lo mejor es simplemente quitar openJDK totalmente y dejar sólo la privativa.
> Ahora que ya la tienes instalada, quitar openJDK (completamente) es
> sencillo:
>
> Abre Synaptic, en la caja «Filtro rápido» escribe «openJDK». De la lista
> mostrada marca para desinstalar completamente los paquetes openjdk-6-jre (u
> openjdk-6-jdk, si instalaste esta o ambas) y la versión 7 del mismo paquete
> (tiene[n] el mismo nombre, cambia el 6 por el 7).
>
> También marca para desinstalar completamente el paquete openjdk-6-jre-lib (y
> la versión 7 del mismo si estuviera instalada).
>
> Con esto se elimina completamente openJDK, incluyendo el plugin para el
> navegador.
>
>
> Saludos,
> Mauricio J. Adonis C.
>
> --
> ubuntu-es mailing list
> ubuntu-es en lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es



More information about the ubuntu-es mailing list