Permisos en partición ext4

Maykel Franco Hernández maykel en maykel.es
Vie Feb 19 21:55:31 GMT 2010


> El 19 de febrero de 2010 17:39, Juan Daniel <jdprigioni en gmail.com>
> escribió:
>
>> El 19 de febrero de 2010 17:25, Maykel Franco Hernández
>> <maykel en maykel.es>escribió:
>>
>> > El 19 de febrero de 2010 13:59, Maykel Franco Hernández
>>> > <maykel en maykel.es>escribió:
>>> >
>>> >> >> Hola usuarios de Ubuntu, les escribo porque tengo un problema con
>>> los
>>> >> >> permisos en una partición que he creado recientemente con el
>>> gparted,
>>> >> el
>>> >> >> propietario de la partición es root y no puedo leer ni escribir.
>>> En
>>> >> un
>>> >> >> tutorial encontré como hacer para que la partición se monte
>>> >> >> automáticamente
>>> >> >> al iniciar el sistema, por lo que he agregado al final del
>>> archivo
>>> >> fstab
>>> >> >> lo
>>> >> >> siguiente: [/dev/sda3 /media/Backup ext4 rw,user 0 0] pero aún
>>> así
>>> no
>>> >> me
>>> >> >> permite escribir o leer en la partición.
>>> >> >> También he intentado cambiar el propietario de la carpeta
>>> >> /media/Backup
>>> >> >> y
>>> >> >> /dev/sda3 con el comando chown -Rf pero sigue sin funcionar.
>>> >> >> Espero puedan ayudarme. Muchas gracias.
>>> >> >>
>>> >> >> --
>>> >> >> Prigioni Juan Daniel
>>> >> >> <jdprigioni en gmail.com>
>>> >> >> --
>>> >> >> ubuntu-es mailing list
>>> >> >> ubuntu-es en lists.ubuntu.com
>>> >> >> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>>> >> >
>>> >> > Pasale el comando mount haber como te lo monta o cat /etc/mtab. Y
>>> >> > muestranos lo que devuelve. Un saludo.
>>> >> >
>>> >>
>>> >
>>> > al hacer cat /etc/mtab me devuelve lo siguiente:
>>> >
>>> > /dev/sda1 / ext4 rw,errors=remount-ro 0 0
>>> > proc /proc proc rw 0 0
>>> > none /sys sysfs rw,noexec,nosuid,nodev 0 0
>>> > none /sys/fs/fuse/connections fusectl rw 0 0
>>> > none /sys/kernel/debug debugfs rw 0 0
>>> > none /sys/kernel/security securityfs rw 0 0
>>> > udev /dev tmpfs rw,mode=0755 0 0
>>> > none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
>>> > none /dev/shm tmpfs rw,nosuid,nodev 0 0
>>> > none /var/run tmpfs rw,nosuid,mode=0755 0 0
>>> > none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
>>> > none /lib/init/rw tmpfs rw,nosuid,mode=0755 0 0
>>> > /dev/sda3 /media/Backup ext4 rw,noexec,nosuid,nodev 0 0
>>> > binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc
>>> rw,noexec,nosuid,nodev
>>> 0
>>> > 0
>>> > gvfs-fuse-daemon /home/jdprigioni/.gvfs fuse.gvfs-fuse-daemon
>>> > rw,nosuid,nodev,user=jdprigioni 0 0
>>> >
>>> > --
>>> > Prigioni Juan Daniel
>>> > <jdprigioni en gmail.com>
>>> > --
>>> > ubuntu-es mailing list
>>> > ubuntu-es en lists.ubuntu.com
>>> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>>>
>>>
>>> Pues tienes permisos de escritura en esta linea:
>>>
>>> /dev/sda3 /media/Backup ext4 rw,noexec,nosuid,nodev 0 0
>>>
>>>
>>> Dale permisos a la carpeta, pero comenta antes la linea de /etc/fstab
>>> para
>>> que no se monte automaticamente.
>>>
>>>
>>> --
>>> ubuntu-es mailing list
>>> ubuntu-es en lists.ubuntu.com
>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>>>
>>
>> Con darle permisos a la carpeta te refieres a /media/Backup que es la
>> carpeta donde se monta la partición? Si es eso ya lo hice pero al hacer
>> sudo
>> mount /dev/sda3 /media/Backup sigo sin tener permisos para escribir o
>> leer
>>
>> --
>> Prigioni Juan Daniel
>> <jdprigioni en gmail.com>
>>
>
> Me parece que el problema esta en la partición, ya que voy a "Equipo" y
> pongo propiedades de la partición y en la pestaña permisos dice que no se
> han podido determinar, este o no este montada la partición en
> /media/Backup.
>
> --
> Prigioni Juan Daniel
> <jdprigioni en gmail.com>
> --
> ubuntu-es mailing list
> ubuntu-es en lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es


Prueba a meterte desde la consola como root en ese directorio con "cd
/media/Backup" haber si te deja ahí crear carpetas con mkdir y demás. Si
no te tira, desmonta la partición con "umount /media/Backup" y cambiale
los permisos siendo root o con "sudo chown usuario:grupousuario
/media/Backup" y luego vuelvela a montar como usuario. Si no te funcionara
todo esto yo haría un fsck de esa partición para ver como esta ese sistema
de ficheros.




Más información sobre la lista de distribución ubuntu-es