VirtualBox conectar a la red

Alfredo Lomán alfredoloman en gmail.com
Jue Feb 4 23:49:31 GMT 2010


El día 3 de febrero de 2010 20:08, Sebastian Abate
<sebastianabate en gmail.com> escribió:
> 2010/2/3 Alfredo Lomán <alfredoloman en gmail.com>:
>> Sebastián:
>>
>> No cambió nada después de seguir tu consejo de bajar el programa VB
>> desde su origen e instalarlo, pero el problema es prácticamente el
>> mismo:
>>
>> Sigo teniendo el icono de red activado en la barra inferior de VB y
>> dentro de VB si pido ver las conexiones de red, estas también están
>> conectadas, pero no hay conexión a la Red ni Internet.
>>
>> Traté de configurar la red en VB poniendo la dirección MAC que me da
>> eth0 pero sigue igual.
>>
>> Ahora quisiera intentar borrar y luego reinstalar WinXP que está
>> dentro de VB pero no sé cómo hacerlo. Cuando borré el VB OSE y
>> reinstalé el nuevo VB, automáticamente me tomó el WinXP que le había
>> instalado en primera instancia. También tengo instalado dentro de
>> WinXP de Vb, Off2003 y ese si es fácil borrar.
>>
>> Saludos
>>
>> El día 2 de febrero de 2010 11:07, Sebastian Abate
>> <sebastianabate en gmail.com> escribió:
>>> 2010/2/2 Alfredo Lomán <alfredoloman en gmail.com>:
>>>> Sebastián:
>>>>
>>>> Gracias por tu apoyo.
>>>>
>>>> Tengo instalado Ubuntu 9.10 para 64 bits, VB 3.0.0.1 OSE que bajé de
>>>> Synaptic, en una partición tengo WXPPro para trabajar con Access, otra
>>>> partición con Ubuntu (en /home tengo disponibles 12 Gb y dentro de
>>>> ellas dejé 10 Gb para VB) y una última partición con Fat32 para
>>>> compartir archivos en ambos SO, HD de 80 Gb.
>>>> Con todas las sugerencias obtenidas, pues estoy desinstalando VB y lo
>>>> volveré a instalar, pues quizá hice algo erróneo la primera vez.
>>>>
>>>> Ya les contaré el resultado.
>>>>
>>>> El día 1 de febrero de 2010 19:32, Sebastian Abate
>>>> <sebastianabate en gmail.com> escribió:
>>>>> 2010/2/1 Alfredo Lomán <alfredoloman en gmail.com>:
>>>>>> Mario Alberto:
>>>>>>
>>>>>> Gracias por tu ayuda.
>>>>>>
>>>>>> He podido ya hacer los dos scripts y ponerlos en su lugar pero no se
>>>>>> dónde poner la línea que me sugieres:
>>>>>>
>>>>>> chmod 700 script.sh
>>>>>>
>>>>>> Al final del script ? la última línea ? dónde
>>>>>>
>>>>>> y por otra parte, he probado ahora que tengo aparentemente todo
>>>>>> resuelto (excepto la línea antes referida),  en la barra inferior de
>>>>>> VirtualBox me dice que estoy conectado a la red, y también en
>>>>>> conexiones a la red me dice lo mismo, pero si pido abrir por ejemplo
>>>>>> la Red o Internet dentro del escritorio de VirtulaBox, me dice que no
>>>>>> hay conexión.
>>>>>>
>>>>>> He tratado de configurar la Red en configuración de Red de VB pero hay
>>>>>> sólo una o dos opciones y sólo una de ellas me da el resultado
>>>>>> anterior.
>>>>>>
>>>>>> Alguna sugerencia ?
>>>>>>
>>>>>> Gracias nuevamente.
>>>>>>
>>>>>> El día 31 de enero de 2010 11:06, Mario Guerra
>>>>>> <guerramarioalberto en gmail.com> escribió:
>>>>>>> Alfredo Lomán escribió:
>>>>>>>> El primer paso no me cuesta trabajo hacerlo pero desde lo relativo a
>>>>>>>> los scripts ni idea tengo de cómo hacerlos y dónde
>>>>>>>> copiarlos/instalarlos.
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>> 1. Los editas con algún editor de textos: vi, nano, gedit, etc:
>>>>>>>
>>>>>>> sudo <tu editor preferido> script.sh
>>>>>>>
>>>>>>> 2. Lo guardas una vez copiado
>>>>>>>
>>>>>>> 3. Indicas que va a ser ejecutable:
>>>>>>>
>>>>>>> chmod 700 script.sh
>>>>>>>
>>>>>>> o
>>>>>>>
>>>>>>> chmod 755 script.sh
>>>>>>>
>>>>>>> Con ésta última, le das permisos a los demás usuarios de ejecutarlo (no
>>>>>>> aconsejable).
>>>>>>>
>>>>>>>> Por otra parte me asalta la duda de si debo tratar el SO de VirtualBox
>>>>>>>> (Windows XP Pro) como es habitual, o sea, instalar drivers, antivirus,
>>>>>>>> hacer actualizaciones, etc.
>>>>>>>>
>>>>>>>
>>>>>>> Sin duda, es como una instalación normal de Windows.
>>>>>>>> La red la necesito para jalar los archivos que tengo que procesar en Access.
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>> Curiosidad. ¿Es posible utilizar tales archivos en Linux?. Hay un
>>>>>>> programita llamado "mdbtools" que quizá pueda serte útil.
>>>>>>>
>>>>>>> sudo apt-get install mdbtools
>>>>>>>
>>>>>>> Saludos cordiales.
>>>>>>>
>>>>>>> Mario
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> ubuntu-es mailing list
>>>>>>> ubuntu-es en lists.ubuntu.com
>>>>>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Con afecto, gusto y placer. Alfredo
>>>>>>
>>>>>> --
>>>>>> ubuntu-es mailing list
>>>>>> ubuntu-es en lists.ubuntu.com
>>>>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>>>>>>
>>>>>
>>>>>
>>>>> Qué versión de VB estás usando?
>>>>>
>>>>> Ya estamos en la 3.1, y desde la versión 2.1 en adelante no hace falta
>>>>> utilizar scripts de ningún tipo, todo se configura desde la interfaz
>>>>> gráfica de VB.
>>>>>
>>>>> Acá pego lo que dice en el manual de VirtualBox en la parte de Networking:
>>>>>
>>>>> The way bridged networking works has been completely rewritten with
>>>>> VirtualBox 2.0 and 2.1, depending on the host operating system. From
>>>>> the user perspective, the main difference is that complex
>>>>> configuration is no longer necessary on any of the supported host
>>>>> operating systems.
>>>>>
>>>>> Que muy a lo bruto quiere decir que desde esa versión (2.0 ó 2.1,
>>>>> según el tipo de guest) ya no es necesario hacer configuraciones
>>>>> complejas, todo funciona automáticamente.
>>>>>
>>>>> Yo utilizo todas los tipos de redes virtuales con variados guest
>>>>> (Windows, Linux, Solaris), y desde hace rato que no tengo que
>>>>> modificar ningún script ni archivo de configuración de Linux.
>>>>> Simplemente lo configuro desde VB y listo.
>>>>>
>>>>> Qué tipo de red tenés seleccionada en la configuración de la VM?
>>>>> probaste con NAT que es la más fácil de configurar? Pasá un poco más
>>>>> de datos sobre la configuración de tu Ubuntu y de tu XP y vemos dónde
>>>>> puede estar el problema.
>>>>>
>>>>> --
>>>>> Sebastián Abate
>>>>> Quattro-D
>>>>> 15-3589-7730
>>>>> abates en quattrod.com.ar
>>>>>
>>>>> --
>>>>> ubuntu-es mailing list
>>>>> ubuntu-es en lists.ubuntu.com
>>>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Con afecto, gusto y placer. Alfredo
>>>>
>>>
>>> OK, pero para que tengas en cuenta, yo usé siempre la versión de VB
>>> descargada de su página, ya que utilizo mucho la conexión USB en las
>>> VM, y la versión OSE no tiene soporte para ello; no creo que esto
>>> signifique alguna diferencia en cuanto a tu problema (networking),
>>> pero me pareció importante aclararlo.
>>>
>>>
>>> --
>>> Sebastián Abate
>>> Quattro-D
>>> 15-3589-7730
>>> abates en quattrod.com.ar
>>>
>>> --
>>> ubuntu-es mailing list
>>> ubuntu-es en lists.ubuntu.com
>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>>>
>>
>>
>>
>> --
>> Con afecto, gusto y placer. Alfredo

Sebastián:

Contesto ty solicitud de información según entiendo el caso, a saber:
>
> No creo que tu problema venga del lado de la instalación de VB (es un
> .deb que se instala como cualquier otro y no tiene casi ninguna
> dependencia rara). = OK

1.- Qué tipo de red tenés seleccionada en tu VM con XP? = Adaptador
solo-anfitrión
2.- Qué IP tiene la VM cuando la arrancás? = En realidad no lo sé pues
en configuración de VB sólo tengo datos de la Dirección MAC pero no
veo dónde buscar la IP
3.- Cómo es la configuración de la red del XP (IP fija o DHCP) =
Tampoco lo sé pues no encuentro el dato.
4.- Cómo es la configuración de red de tu Ubuntu (IP fija o DHCP,
firewall habilitado o no, etc)= Me conecto a un Modem de la Cia.
Telefónica (TELMEX) via cable, de ese Modem sale un cable a un
Servidor de donde obtengo mis archivos de trabajo diario, que tiene 4
discos duros en RAID, 2 para SO y 2 para archivos, y en ese mismo
Modem conecto otras computadoras a reparación también con cable, pero
si la computadora por reparar tiene wireless, pues la conecto por esa
vía, tanto en Ubuntu como en WinXP que tengo en otra partición (no el
nuevo de VB).
Creo que la IP es fija pero no estoy cierto y actualmente tengo
deshabilitado el firewall del Modem pues no me ha funcionado muy bien
la configuración actual de red, la cual pienso cambiar a otra
estructura antigua, funcionaba mejor, mediante un router o switch.

Respuesta a comando Ubuntu lshw (listado general de equipo instalado)
*-network
       description: Ethernet interface
       physical id: 1
       logical name: vboxnet0
       serial: 0a:00:27:00:00:00
       capabilities: ethernet physical
       configuration: broadcast=yes ip=192.168.56.1 multicast=yes

Ojalá te hayan servido mis datos y si se requieren más, pues dímelo.

Gracias mil

>
> Por casualidad tenés algún cd o imagen ISO de Ubuntu (9.04 o 9.10)?
> Probá crear una nueva VM con las opciones que vienen por defecto
> (sobre todo verificá que el tipo de red sea NAT) utilizando el CD o la
> imagen ISO y arrancá esa VM; y verificá si podés acceder a internet.
>
> Para borrar una VM no tenés más que darle click con el botón derecho y
> seleccionar delete, y después presionás ctrl+d para que abra el
> administrador de medios y seleccionás el disco virtual de la vm que
> acabás de borrar y le das click al botón Remove.
>
> --
> Sebastián Abate
> Quattro-D
> 15-3589-7730
> abates en quattrod.com.ar
>
> --
> ubuntu-es mailing list
> ubuntu-es en lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>



-- 
Con afecto, gusto y placer. Alfredo



Más información sobre la lista de distribución ubuntu-es