Problemas con samba...

Sebastian Abate sebastianabate en gmail.com
Dom Ene 11 14:16:41 GMT 2009


2009/1/11 Fidel Dominguez-Valero <433411 en gmail.com>:
> Sebastian Abate wrote:
>>
>> On Sat, Jan 10, 2009 at 11:07 PM, Fidel Dominguez-Valero
>> <433411 en gmail.com> wrote:
>>
>>>
>>> Hola mi gente, tengo tres pc en la casa conectadas con un 2wire todas
>>> tienen internet pero quiero compartior un folder para copiar algunas
>>> cosas entre otras cosas pero caundo ejecuto:
>>> sudo apt-get install samba
>>>
>>> el resultado es el siguiente:
>>>
>>> Reading package lists... Done
>>> Building dependency tree
>>> Reading state information... Done
>>> Some packages could not be installed. This may mean that you have
>>> requested an impossible situation or if you are using the unstable
>>> distribution that some required packages have not yet been created
>>> or been moved out of Incoming.
>>>
>>> Since you only requested a single operation it is extremely likely that
>>> the package is simply not installable and a bug report against
>>> that package should be filed.
>>> The following information may help to resolve the situation:
>>>
>>> The following packages have unmet dependencies:
>>>  samba: Depends: samba-common (= 3.0.28a-1ubuntu4) but
>>> 3.0.28a-1ubuntu4.4 is to be installed
>>> E: Broken packages
>>>
>>>
>>> Alguna idea de como solucionar esto, cuando intento quitar el
>>> samba-common me dice q tambien desintalara ubuntu-desktop, por lo q no
>>> continuo.
>>> espero ayuda
>>> Gracias de antemano
>>> fdvalero
>>>
>>>
>>> --
>>> ubuntu-es mailing list
>>> ubuntu-es en lists.ubuntu.com
>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>>>
>>>
>>
>> Aparentemente tenés desactualizada la base de repositorios de apt,
>> fijate que te está diciendo que el paquete que querés instalar
>> necesita un samba-common con versión 3.0.28a-1ubuntu4, y el que está
>> disponible para instalar es el de versión 3.0.28a-1ubuntu4.4 (un .4
>> más nuevo, por decirlo de alguna forma).
>>
>> Probá haciendo un "sudo apt-get clean" para que borre todos los
>> paquetes que tengas guardados en el cache de apt (no te preocupes que
>> esto lo único que hace es borrar los archivos .deb que apt baja cuando
>> los instalás o actualizás Ubuntu, no te desinstala ninguno de ellos),
>> después hacé un "sudo apt-get update && sudo apt-get upgrade" para que
>> actualice los paquetes disponibles en los repositorios y después
>> instale todas las versiones nuevas que haya de los paquetes. Después
>> hacé un "sudo apt-get install -f" para que instale y configure
>> cualquier paquete que haya quedado sin hacerlo; y por último volvé a
>> tratar de instalar samba.
>>
>>
>
> realice todo eso y me da el mismo error
> q hago??
>

Es muy raro, lo único que se me ocurre es que tengas algún repositorio
activo que contiene la última versión de samba-common, pero no todos
los demás paquetes relacionados, y eso trae conflicto con las
dependencias.

Probá deshabilitando desde Synaptic todos los repositorios de
terceros, y en la solapa de updates los repositorios proposed y
backports; después volvé a ejecutar los comandos que te mencioné en el
mail anterior y decinos qué pasó.

-- 
Sebastián Abate
Quattro-D
15-3589-7730
abates en quattrod.com.ar



Más información sobre la lista de distribución ubuntu-es