VirtualBox en Ubuntu - Intrepid Ibex

Hugo Alonso vvosca en gmail.com
Jue Nov 6 07:07:32 GMT 2008


2008/11/6 UNE-Carlos E. Pruna Capdevila <carlosepc en oc.une.cu>

>  Desde que actualice mi Ubuntu Hardy a Intrepid Ibex mi virtualbox me dejo
> de pinchar, empecé a buscar y era que como había cambiado la versión del
> kernel de la 2.6.24 a la 2.6.27-7 ya no existía el virtualbox-ose-modules
> para esa versión del kernel, mando esto por si a alguien se mete en este
> enredo....
>
>
> Si venías usando VirtualBox en Ubuntu 8.04LTS, lo habitual era tener que
> instalar el paquete con el módulo apropiado para el kernel que se usaba: Por
> ejemplo *virtualbox-ose-modules-2.6.24-19-generic*.
>
> El problema es que en Intrepid Ibex no hay un módulo que soporte el kernel
> por defecto (2.6.27-7). La solución es sencilla:
>
>
>    1. Instala el paquete "dkms". Es un paquete que se encarga de
>    monitorizar el software que depende del kernel y si hay cambios en el kernel
>    y están las fuentes del paquete, lo recompila solo.
>    2. Instala las cabeceras del kernel "linux-headers-generic", por
>    ejemplo.
>    3. Instala las fuentes del driver OSE de VirtualBox:
>    "virtualbox-ose-source".
>
>
> Este tercer paso hará que se compile e instale el driver, y tachán,
> VirtualBox funcionando de nuevo y además si hay cualquier cambio de kernel
> en el futuro, pues con mucha probabilidad se recompilará y funcionará sin
> tener que instalar más paquetes :).
>
>
Alguna vez me he encontrado con este problema. Mi solución era simple, no
actualizar el kernel en cuanto salía, sino esperar unos días para dar tiempo
a que saliera el driver de virtualbox.

Anoto este mail como información valiosa ;)

Gracias!

-- 
Hugo Alonso.
------------ próxima parte ------------
Se ha borrado un adjunto en formato HTML...
URL: https://lists.ubuntu.com/archives/ubuntu-es/attachments/20081106/f2504d53/attachment.htm 


Más información sobre la lista de distribución ubuntu-es