Problemas que no he podido resolver en Hardy

Reynier Perez Mira rperezm en uci.cu
Jue Jun 26 15:33:35 BST 2008


> Yo tengo un Dell LATITUDE D620 y tengo aún más problemas que 
> con las versiones anteriores con el tema de la hibernación y 
> suspensión. Se me cambia la resolución, pantalla en negro que 
> no responde. Un desastre.
> Pero mucho me temo que es más un tema del propio kernel del 
> Linux en general.
> Cualquier ayuda será bienvenida.

Hola Aitor y demás listeros:
He estado intercambiando algunos mensajes en el Foro de ubuntu-es y me han dicho que los problemas de hibernación pueden estar causado por los drivers de mi tarjeta gráfica que es una ATI. Me han comentado también que la solución era descargarme los drivers privativos que recientemente sacó ATI. Así lo he hecho pero cuando me he dispuesto a instalarlos me da algunos errores:

reynierpm en rpm:~/Downloads$ ./ati-driver-installer-8-6-x86.x86_64.run 
Created directory fglrx-install.rY7844
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.501...
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.24-19-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.rY7844

Imagino que los mismos sea cosa de SELinux pero bueno. He seguido adelante con el proceso de instalación pero esta vez comprobando que paquetes puedo generar con el mismo. Observen los resultados:

reynierpm en rpm:~/Downloads$ ./ati-driver-installer-8-6-x86.x86_64.run --listpkg
Created directory fglrx-install.MM8075
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.501...
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================
List of generatable packages:

Package Maintainer(s): Aric Cyr <aric.cyr en gmail.com>
                      Mario Limonciello <superm1 en gmail.com>
Status: *UNVERIFIED*
Debian Packages:
	Debian/sarge
	Debian/oldstable
	Debian/sid
	Debian/unstable
	Debian/etch
	Debian/stable
	Debian/lenny
	Debian/testing
	Debian/experimental

Package Maintainer(s): Niko Mirthes <nmirthes en gmail.com>
                      Michael Larabel <michael en phoronix.com>
Status: *UNVERIFIED*
Fedora Packages:
	Fedora/FC3
	Fedora/FC4
	Fedora/FC5
	Fedora/FC6
	Fedora/F7
	Fedora/F8
	Fedora/F9
	Fedora/RHEL3
	Fedora/RHEL4

Package Maintainer(s): Anssi Hannula <anssi en mandriva.com>
Status: *UNVERIFIED*
Mandriva Packages:
	Mandriva/2006
	Mandriva/2007
	Mandriva/2008

Package Maintainer(s): Bowen Zhu <bwzhu en redflag-linux.com>
Status: *UNVERIFIED*
RedFlag Packages:
	RedFlag/RF50
	RedFlag/RF60

Package Maintainer(s): ATI
Status: Verified
RedHat Packages:
	RedHat/RHEL4_64a
	RedHat/RHEL4
	RedHat/RHEL5_64a
	RedHat/RHEL5

Package Maintainer(s): Emanuele Tomasi <tomasi en cli.di.unipi.it>
                      Ezio Ghibaudo <ekxius en gmail.com>
                      Federico Rota <federico.rota01 en gmail.com>
Status: *UNVERIFIED*
Slackware Packages:
	Slackware/Only
	Slackware/root
	Slackware/can
	Slackware/do
	Slackware/it!

Package Maintainer(s): Stefan Dirsch <sndirsch en suse.de>
Status: *UNVERIFIED*
SuSE Packages:
	SuSE/SLED10-IA32
	SuSE/SLES10-IA32
	SuSE/SUSE101-IA32
	SuSE/SLED10-AMD64
	SuSE/SLES10-AMD64
	SuSE/SUSE101-AMD64
	SuSE/SUSE102-IA32
	SuSE/SUSE103-IA32
	SuSE/SUSE102-AMD64
	SuSE/SUSE103-AMD64

Package Maintainer(s): Mario Limonciello <superm1 en gmail.com>
                      Aric Cyr <aric.cyr en gmail.com>
Status: *UNVERIFIED*
Ubuntu Packages:
	Ubuntu/dapper
	Ubuntu/6.06
	Ubuntu/edgy
	Ubuntu/6.10
	Ubuntu/feisty
	Ubuntu/7.04
	Ubuntu/gutsy
	Ubuntu/7.10
	Ubuntu/hardy
	Ubuntu/8.04
	Ubuntu/intrepid
	Ubuntu/8.10

For example, to build a Debian Etch package, run the following:
% ./ati-driver-installer-<version>-<architecture>.run --buildpkg Debian/etch

Como verán genera paquetes para Ubuntu Hardy 8.04 y eso es lo que he hecho:

reynierpm en rpm:~/Downloads$ ./ati-driver-installer-8-6-x86.x86_64.run --buildpkg Ubuntu/8.04
Created directory fglrx-install.FX8246
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.501...
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================
Generating package: Ubuntu/8.04
Resolving build dependencies...
Unable to resolve  cannot read packages/Ubuntu/dists/8.04/control.  Please manually install and try again.
Package /home/reynierpm/Downloads/xorg-driver-fglrx_8.501-0ubuntu1_i386.deb has been successfully generated
Package /home/reynierpm/Downloads/xorg-driver-fglrx-dev_8.501-0ubuntu1_i386.deb has been successfully generated
Package /home/reynierpm/Downloads/fglrx-kernel-source_8.501-0ubuntu1_i386.deb has been successfully generated
Package /home/reynierpm/Downloads/fglrx-amdcccle_8.501-0ubuntu1_i386.deb has been successfully generated
Removing temporary directory: fglrx-install.FX8246

Ahora eso me generó los siguientes paquetes:
 fglrx-amdcccle_8.501-0ubuntu1_i386.deb       
 xorg-driver-fglrx_8.501-0ubuntu1_i386.deb
 fglrx-installer_8.501-0ubuntu1_i386.changes  
 xorg-driver-fglrx-dev_8.501-0ubuntu1_i386.deb
 fglrx-kernel-source_8.501-0ubuntu1_i386.deb

¿Cual(es) de ellos instalo? ¿Todos o solo algunos?

Salu2
Ing. Reynier Pérez Mira
Grupo de Soporte al Desarrollo - Dirección Técnica IP  



Más información sobre la lista de distribución ubuntu-es