problemas con xrand, portatil y pantalla TFT

David Ballester ballester.david en gmail.com
Vie Jun 20 09:47:26 BST 2008


2008/6/20 Sergio Ruiz <sruiz en experienceis.com>:

> Hola,
>
> tengo ubunti 7.10 corriendo en un portátil HP 6720s, con driver intel.
> Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller
>
> también tengo el módulo para el kernel agpgart activado:
> agpgart: Detected an Intel 965GM Chipset.
>
> la idea es conectar ubn TFT DELL de 19" al portátil y extender el
> escritorio.
>
> me estoy encontrando con problemas, y  sólo me clona el escritorio.
>
> utilizando el displayconfig-gtk sólo me detecta una pantalla, y no puedo
> hacer nada
> más.
> He cambiado mi xorg.conf configurándolo para dos monitores de la siguiente
> manera y
> activando xinerama, aunque con pésimo resultado:
> ....
> Section "Device"
>        Identifier      "Intel Portatil"
>        Driver          "intel"
>        BusID           "PCI:0:2:0"
>        Screen 0
> EndSection
>
>
> Section "Device"
>        Identifier      "Dell"
>        Driver          "intel"
>        BusID           "PCI:0:2:0"
>        Screen 1
> EndSection
>
>
> Section "Monitor"
>        Identifier      "Portatil"
>        Option          "DPMS"
>        HorizSync       28-64
>        VertRefresh     43-60
> EndSection
>
> Section "Monitor"
>        Identifier      "Dell"
>        Option          "DPMS"
>        HorizSync       28-72
>        VertRefresh     43-60
> EndSection
>
>
> Section "Screen"
>        Identifier      "Portatil"
>        Device          "Intel Portatil"
>        Monitor         "Portatil"
>        DefaultDepth    24
>        SubSection "Display"
>              Modes           "1280x800 en 60" "1280x768 en 60" "1200x800 en 60"
> "800x600 en 60"
>        EndSubSection
> EndSection
>
> Section "Screen"
>        Identifier      "Dell"
>        Device          "Dell"
>        Monitor         "Dell"
>        DefaultDepth    24
>        SubSection "Display"
>                Modes           "1440x900 en 60" "1400x1050 en 60" "1280x1024 en 60"
> "1280x960 en 60" "1280x854 en 60" "1280x800 en 60" "1280x768 en 60" "1200x800 en 60"
> "1152x864 en 60"
> "1152x768 en 60" "1024x768 en 60"
> EndSubSection
> EndSection
>
>
>
> Section "ServerLayout"
>        Identifier      "Default Layout"
>        Option "Xinerama" "on"
>        Screen          "Portatil"
>        Screen          "Portatil" RigthOf "Dell"
>        Screen          "Dell"
>        InputDevice     "Generic Keyboard"
>        InputDevice     "Configured Mouse"
>
> # Uncomment if you have a wacom tablet
> #       InputDevice     "stylus"        "SendCoreEvents"
> #       InputDevice     "cursor"        "SendCoreEvents"
> #       InputDevice     "eraser"        "SendCoreEvents"
>        InputDevice     "Synaptics Touchpad"
> EndSection
>
>
> esto sólo me detecta un monitor.
>
>
>
> También he intentado utilizar xrandr, pero me dá errores con el driver
> intel:
>
> ~$ xrandr -v
> Server reports RandR version 1.2
>
> $ xrandr -q
> X Error of failed request:  BadRequest (invalid request code or no such
> operation)
>  Major opcode of failed request:  151 (RANDR)
>  Minor opcode of failed request:  6 ()
>  Serial number of failed request:  9
>  Current serial number in output stream:  9
>
>
> Si cambio el driver de intel por el de vesa (reiniciando) xrandr me
> funciona, pero
> no me detecta el TFT.
>
>
>
Échale un vistazo a este post, creo que te faltan pasos a realizar

http://ubuntuforums.org/showpost.php?p=4003194&postcount=584


D.
------------ próxima parte ------------
Se ha borrado un adjunto en formato HTML...
URL: https://lists.ubuntu.com/archives/ubuntu-es/attachments/20080620/9b723cea/attachment-0001.htm 


Más información sobre la lista de distribución ubuntu-es