instalar mono en ubuntu <desde las fuentes, no encuentra glib>

David Cancio Reyes ddcors en gmail.com
Jue Oct 25 07:34:57 BST 2007


Hola.
    Tengo 
        Ubuntu 7.04 feisty fawn 
        Linux Kernel 2.6.20-16-generic
        gcc-4.1
    Descargue las fuentes de mono
        * mono-1.2.4.tar.bz2
        * mono-basic-1.2.4.tar.bz2
        * libgdiplus-1.2.4.tar.bz2
    
    Quiero instalar mono desde estas fuentes, entonces descomprimo asi:
        $tar -xjvf mono-1.2.4.tar.bz2

    Me cambio al directorio creado asi:
        $cd mono-1.2.4

    Leo el README y dice <entre otras cosas> que debo tener la libreria
    glib, que si la tengo porque la busque en Synaptic y marca que ya
    la tengo instalada, entonces hago:
        #./configure --prefix=/usr/local

    Hace lo que tiene que hacer eso pero a lo último dice que no  
    encuentra la libreria glib instalada, que la añada a la variable
    PKG_CONFIG_PATH...
     
    Entonces hice esto:
        # export PKG_CONFIG_PATH=/usr/local/lib/

        y luego volvi a configurar con ./configure pero sigue saliendo
        el mismo error


....Y ya andube indagando en la internet pero nada...casi todos lo
instalan desde los repositorios o .bin o .rpm... pero yo quiero hacerlo
desde las fuente.....Si saben algo, por favor ayuden, gracias!



Mas abajo dejo la salida que produce el
comando ./configure.....traducida al español de un ingles muy malo que
tengo y hasta abajo como aparece en la terminal, en ingles.


















    <segun lo que entiendo TRADUCIDO AL ESPAÑOL>
       
        Paquete glib - 2.0 no fue encontrado en el paquete de           
        configuración de la ruta de búsqueda.

        Tal vez debería añadir el directorio que contiene `glib 2.0.pc
        A la variable de entorno PKG_CONFIG_PATH

        Ningún paquete 'glib - 2.0' encontrados 



        - 2,0 gthread paquete no se encontró en el paquete de
        configuración de la ruta de busqueda.

        Tal vez debería añadir el directorio que contiene `gthread2.0.pc
        A la variable de entorno PKG_CONFIG_PATH

        Ningún paquete 'gthread - 2.0'

        

        Ningún paquete 'glib - 2.0' encontrados 

        Considerar la posibilidad de ajustar la variable de entorno
        PKG_CONFIG_PATH si Software instalado en un prefijo no
        estándar. 

        Alternativamente, puede configurar las variables de entorno
        BASE_DEPENDENCIES_CFLAGS BASE_DEPENDENCIES_LIBS y para evitar la
        necesidad de pedir paquete de configuración. Véase el paquete de
        configuración de página de manual para más detalles.



        LA VERSION ORIGINAL DEL ERROR ESTA EN INGLES Y ES ESTA:

                checking for pkg-config... /usr/bin/pkg-config
                Package glib-2.0 was not found in the pkg-config search
                path. 

                Perhaps you should add the directory containing
                `glib-2.0.pc' to the PKG_CONFIG_PATH environment
                variable 

                No package 'glib-2.0' found
        
                Package gthread-2.0 was not found in the pkg-config
                search path.
                
                Perhaps you should add the directory containing
                `gthread-2.0.pc'to the PKG_CONFIG_PATH environment
                variable
        
                No package 'gthread-2.0' found


                Package glib-2.0 was not found in the pkg-config search
                path. Perhaps you should add the directory containing
                `glib-2.0.pc' to the PKG_CONFIG_PATH environment
                variable

                No package 'glib-2.0' found
                
                Package gthread-2.0 was not found in the pkg-config
                search path.
                
                Perhaps you should add the directory containing         
                `gthread-2.0.pc' to the PKG_CONFIG_PATH environment
                variable        
                No package 'gthread-2.0' found
                checking pkg-config is at least version 0.9.0... yes
                checking for BASE_DEPENDENCIES... configure: error:
                Package requirements (glib-2.0 >= 1.3.11) were not met:
                No package 'glib-2.0' found
                Consider adjusting the PKG_CONFIG_PATH environment
                variable if you
                installed software in a non-standard prefix.
                Alternatively, you may set the environment variables
                 BASE_DEPENDENCIES_CFLAGS
                and BASE_DEPENDENCIES_LIBS to avoid the need to call
                 pkg-config.
                See the pkg-config man page for more details.




Más información sobre la lista de distribución ubuntu-es