Problemas con lm-sensors

Ignacio Hernan herje en forodelinux.org
Jue Nov 11 12:02:17 CST 2004


Distro: Ubuntu-Linux
Nucleo: Linux platas 2.6.8.1-3-686-smp #1 SMP Tue Oct 12 13:40:26 BST
2004 i686 GNU/Linux
Equipo: PIV a 3.4 Ghz procesador SMP

El problema:

Imposible hacer funcionar lm_sensors por ahora. He instalado lm-sensors,
i2c está soportado en nucleo, pero lo que no he encontrado es el paquete
i2c que creo que hace falta también.
Al hacer una busqueda en las fuentes me tira esto:

------------------
root en platas /home/herje # apts i2c
eep24c - read and write serial I2C eeprom devices
gdesklets-data - displays and sensors for gdesklets
kernel-patch-2.4-i2c - Drivers for the i2c bus
libglui2c102 - GLUI, a C++ GLUT based GUI library - runtime support
lm-sensors - Utilities to read temperature/voltage/fan sensors
sensord - Hardware sensor information logging daemon
smartcard - A smartcard utility for Linux
wmgtemp - Temperature sensor dockapp for Window Maker
xml-rpc-api2cpp - Generate C++ wrapper classes for XML-RPC servers.
root en platas /home/herje #
------------

De todos modos he tratado de correr "sensors-detect" y me dice lo
siguiente:

-------------
root en platas /home/herje # sensors-detect
No i2c device files found. Use prog/mkdev/mkdev.sh to create them.
root en platas /home/herje #
-------------

El caso es que he visto Googleando que debía también añadir la linea
"/usr/local/lib" al fichero /etc/ld.so.conf y tanbién está hecho, pero
si trato de correr el dichoso "prog/mkdev/mkdev.s" o
"prog/mkdev/mkdev.s" me da por respuesta "No existe el fichero o el
directorio" y efectivamente haciendo un "locate" tras updatear la db no
existe.

¿Será simplemente que me falta el paquete i2c?

Las fuentes que tengo en Ubuntu son las siguientes:

-------------
deb http://archive.ubuntu.com/ubuntu warty main restricted
deb-src http://archive.ubuntu.com/ubuntu warty main restricted
deb http://archive.ubuntu.com/ubuntu warty universe multiverse
deb-src http://archive.ubuntu.com/ubuntu warty universe multiverse

deb http://security.ubuntu.com/ubuntu warty-security main restricted

deb-src http://security.ubuntu.com/ubuntu warty-security main restricted

(las lineas seguidas, claro está)
-----------------------


¿Alguna idea?

Gracias.


-- 
Saludos
Ignacio Hernán (Herje)
http://www.herje.com






More information about the ubuntu-es mailing list