PolicyKit and ConsoleKit issues

Angie T. Muhammad angie.tawfik at gmail.com
Sat Aug 22 23:16:23 UTC 2009

Hello Guys
Ramadan Kareem :)

For one week I've been experiencing problems with my ubuntu 9.04 desktop.
Since its last update, I experienced these symptoms:
- NetworkManager and Bluetooth services though supposedly working ('#
service NetworkManager status' returns it's running) they never appear on
- wlan0 and sound card are no longer working > I solved the sound card thing
by adding my user account to necessary audio groups but the sound is now
- Once the screen is locked, it refuses to unlock using the correct password
> I swear the password is right because it works on command line doing an su
- $USER.
I tried this with 3 different accounts, and the same passwords work
peacefully when logging in after rebooting but NOT when the screen is
- Most of GUI utilities like HW testing produce errors and refuse to start.

I'm attaching the my /var/log/messages .. I highly suspect ConsoleKit and
PolicyKit for the troubles as the file explains.. since console kit is
responsible for sessions, seats and users authentication while policy kit is
responsible for having unprivileged processes speak with privileged ones.. I
think both kits are denying me many aspects of the system. I noticed that
console-kit-daemon wasn't running and on my many attempts it refuses to

I did an # dpkg --status consolekit
and found the package is optional.. but trying # apt-get purge consolekit
showed that it will remove around 60 packages mostly gnome. The same thing
applies to policykit.. I'm in a bad need of getting my system healthy
again.. Your help is really appreciated guys and you may "yenobko fia thawab
:D "

N.B: writing from CentOS

All the best,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-eg/attachments/20090823/4a3004f6/attachment.html>

More information about the Ubuntu-eg mailing list