Error 11: Unrecognized Device String

Merve Uluser merveuluser at
Sun Dec 6 13:02:42 UTC 2009

I don't know if it was solved before but I managed to solve this problem yesterday in my Jaunty and now wanna explain it, if I'm wrong about something, please let me know.

In Jaunty Jackalope, I was prompted to install updates. When I was done with them, I restarted my computer and it gave an error:

root e2074b73-750b-4442-8533-9849422f47b2

Error 11: Unrecognized Device String

Press any key...

After searching around the internet, I've got nothing but to install GRUB again. I used Live CD to install GRUB again but it wouldn't work. Then I found out that the problem was about "uuid"s. In menu.lst:

title		Debian GNU/Linux, kernel 2.6.28-15-generic
root		e2074b73-750b-4442-8533-9849422f47b2
kernel		/boot/vmlinuz-2.6.28-15-generic root=UUID=e2074b73-750b-4442-8533-9849422f47b2 ro quiet splash
initrd		/boot/initrd.img-2.6.28-15-generic

root was wrong, it should be uuid after installing updates but however, my Jaunty failed to manage that. So I manually changed it all to root and it worked for me. 

Just one more problem, I get an error when I try to install any package, it is installed later but I see an error message like that:

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

It's not important for now but if anyone knows what the problem is, I'd like to hear it.

Yeni Windows 7: Size en uygun bilgisayarı bulun. Daha fazla bilgi edinin.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-doc mailing list