<meta charset="utf-8"><div><blockquote class="gmail_quote" style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0.8ex; border-left-width: 1px; border-left-color: rgb(204, 204, 204); border-left-style: solid; padding-left: 1ex; ">

CFFI seems to be packaged as cl-cffi. It's probably a bit outdated, as it hasn't been updated for a year or so, but it's there. If it doesn't work there are no bug reports indicating that. No idea about threads.</blockquote>

</div><div><br></div>My mistake, CLISP indeed has CFFI, though thread support is questionable. I'm not sure if Hunchentoot's thread trouble is Bordeaux Threads' problem or CLISP's problem.<div><br></div><div>

<blockquote class="gmail_quote" style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0.8ex; border-left-width: 1px; border-left-color: rgb(204, 204, 204); border-left-style: solid; padding-left: 1ex; ">

Can't test it, there is no report on Launchpad.</blockquote><meta charset="utf-8"><div><br></div><div>Launchpad <i>does</i> contain a <a href="https://bugs.launchpad.net/sbcl/+bug/725881">bug report</a> for SBCL on Xen--I submitted it myself.<br clear="all">

<div><br></div><div><blockquote class="gmail_quote" style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0.8ex; border-left-width: 1px; border-left-color: rgb(204, 204, 204); border-left-style: solid; padding-left: 1ex; ">

This one looks like an easy fix as it probably lacks a rebuild. I'll do it later.</blockquote></div><div><br></div><div>That's kind of you to do the rebuild of ECL.</div><div><br></div><div>Why was OpenMCL removed? Could CCL be added now?</div>

</div><div><br></div><div>Aye, GCL looks defunct.</div><div><br></div><div>I realize improvements are more likely to happen at the Debian repositories first. I'd CC this to their mailing list, but I'm not confirmed on it yet.</div>

<div><br></div>Cheers,<div><br></div><div>Andrew Pennebaker</div><div><a href="http://www.yellosoft.us" target="_blank">www.yellosoft.us</a></div><br>
<br><br><div class="gmail_quote">On Wed, Mar 2, 2011 at 11:38 AM, Krzysztof Klimonda <span dir="ltr"><<a href="mailto:kklimonda@ubuntu.com">kklimonda@ubuntu.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

<div class="im">On Wed, 2011-03-02 at 03:15 -0500, Andrew Pennebaker wrote:<br>
> CLISP works, but it's missing CFFI and threads.<br>
<br>
</div>CFFI seems to be packaged as cl-cffi. It's probably a bit outdated, as<br>
it hasn't been updated for a year or so, but it's there. If it doesn't<br>
work there are no bug reports indicating that. No idea about threads.<br>
<div class="im">><br>
> SBCL crashes during installation on Xen hosts.<br>
<br>
</div>Can't test it, there is no report on Launchpad. If that's the case it<br>
should be reported. The only distantly related bug I've found is<br>
<a href="http://bugs.debian.org/559954" target="_blank">http://bugs.debian.org/559954</a> but it talks about OpenVZ, not Xen guests,<br>
and is not going to get fixed.<br>
><br>
><br>
> ECL crashes during installation.<br>
<br>
This one looks like an easy fix as it probably lacks a rebuild. I'll do<br>
it later. I'm surprised that it fails on maverick, as it had two<br>
uploads, but they were early in the cycle - possible that it happened<br>
before we have dropped support for i486 (which removed the symlink).<br>
<div class="im"><br>
><br>
><br>
> OpenMCL hasn't been updated since Dapper. And it's called CCL now, by<br>
> the way.<br>
<br>
</div>It has been removed from Debian, and then deleted from Ubuntu during<br>
feisty development cycle.<br>
<div class="im"><br>
><br>
> ABCL doesn't have an entry in Aptitude.<br>
<br>
</div>Hasn't been packaged by anyone - there is the ITP bug reported on the<br>
Debian BTS though: <a href="http://bugs.debian.org/608466" target="_blank">http://bugs.debian.org/608466</a><br>
<div class="im"><br>
><br>
><br>
> GCL is so old, it doesn't export the package :CL (and therefore can't<br>
> work with Quicklisp).<br>
<br>
</div>We have the most recent version packaged, also natty has the same<br>
version that Debian ships (it has an astounding number of 87 revisions).<br>
Upstream has not released a new version of gcl since 2005, if it's old<br>
it's because they don't work on it (or at least don't release it).<br>
<br>
Cheers,<br>
<font color="#888888">  KK<br>
</font></blockquote></div><br></div>